summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 19:57:02 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 19:57:02 +0000
commit8ef38186faea3d9b5e6f0f1242f668cb7e7a3d52 (patch)
tree9253f150814c99167239f7c2cc850cdd9d92c003 /c/src/lib/libcpu/powerpc/configure.in
parentEnsure that when -msoft-float is specified for multilib builds, that (diff)
downloadrtems-8ef38186faea3d9b5e6f0f1242f668cb7e7a3d52.tar.bz2
Patch from John Cotton <john.cotton@nrc.ca>, Charles-Antoine Gauthier
<charles.gauthier@iit.nrc.ca>, and Darlene A. Stewart <Darlene.Stewart@nrc.ca> to add support for a number of very significant things: + BSPs for many variations on the Motorola MBX8xx board series + Cache Manager including initial support for m68040 and PowerPC + Rework of mpc8xx libcpu code so all mpc8xx CPUs now use same code base. + Rework of eth_comm BSP to utiltize above. John reports this works on the 821 and 860
Diffstat (limited to 'c/src/lib/libcpu/powerpc/configure.in')
-rw-r--r--c/src/lib/libcpu/powerpc/configure.in34
1 files changed, 17 insertions, 17 deletions
diff --git a/c/src/lib/libcpu/powerpc/configure.in b/c/src/lib/libcpu/powerpc/configure.in
index dfeed3d186..db92d4bc8f 100644
--- a/c/src/lib/libcpu/powerpc/configure.in
+++ b/c/src/lib/libcpu/powerpc/configure.in
@@ -26,16 +26,20 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
-AM_CONDITIONAL(shared,
-test "$RTEMS_CPU_MODEL" = "mpc750" \
-|| test "$RTEMS_CPU_MODEL" = "mpc604" )
+AM_CONDITIONAL(shared, test "$RTEMS_CPU_MODEL" = "mpc750" \
+|| test "$RTEMS_CPU_MODEL" = "mpc604" \
+|| test "$RTEMS_CPU_MODEL" = "mpc6xx" \
+|| test "$RTEMS_CPU_MODEL" = "mpc821" \
+|| test "$RTEMS_CPU_MODEL" = "mpc860" \
+|| test "$RTEMS_CPU_MODEL" = "mpc8xx" )
AM_CONDITIONAL(mpc505, test "$RTEMS_CPU_MODEL" = "mpc505")
AM_CONDITIONAL(mpc6xx, test "$RTEMS_CPU_MODEL" = "mpc6xx" \
|| test "$RTEMS_CPU_MODEL" = "mpc604" \
|| test "$RTEMS_CPU_MODEL" = "mpc750" )
-AM_CONDITIONAL(mpc821, test "$RTEMS_CPU_MODEL" = "mpc821")
-AM_CONDITIONAL(mpc860, test "$RTEMS_CPU_MODEL" = "mpc860")
+AM_CONDITIONAL(mpc8xx, test "$RTEMS_CPU_MODEL" = "mpc8xx" \
+|| test "$RTEMS_CPU_MODEL" = "mpc821" \
+|| test "$RTEMS_CPU_MODEL" = "mpc860" )
AM_CONDITIONAL(ppc403, test "$RTEMS_CPU_MODEL" = "ppc403")
# Explicitly list all Makefiles here
@@ -44,18 +48,14 @@ Makefile
mpc505/Makefile
mpc505/timer/Makefile
mpc505/vectors/Makefile
-mpc821/Makefile
-mpc821/clock/Makefile
-mpc821/console-generic/Makefile
-mpc821/include/Makefile
-mpc821/timer/Makefile
-mpc821/vectors/Makefile
-mpc860/Makefile
-mpc860/clock/Makefile
-mpc860/console-generic/Makefile
-mpc860/include/Makefile
-mpc860/timer/Makefile
-mpc860/vectors/Makefile
+mpc8xx/Makefile
+mpc8xx/clock/Makefile
+mpc8xx/console-generic/Makefile
+mpc8xx/cpm/Makefile
+mpc8xx/include/Makefile
+mpc8xx/mmu/Makefile
+mpc8xx/timer/Makefile
+mpc8xx/vectors/Makefile
ppc403/Makefile
ppc403/clock/Makefile
ppc403/console/Makefile