summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-12 22:04:28 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2004-04-12 22:04:28 +0000
commit8430205c224c1bfcb67156e5b97dd44ecd81fd7d (patch)
tree5ce5170ec6f228407d7ebfab0c1efbf17c495595 /c/src/lib/libcpu/powerpc/configure.ac
parent2004-04-12 David Querbach <querbach@realtime.bc.ca> (diff)
downloadrtems-8430205c224c1bfcb67156e5b97dd44ecd81fd7d.tar.bz2
2004-04-12 David Querbach <querbach@realtime.bc.ca>
* README, configure.ac, mpc5xx/Makefile.am, mpc5xx/exceptions/raw_exception.c, mpc5xx/exceptions/raw_exception.h, mpc5xx/timer/timer.c, shared/include/cpuIdent.h: addition of a significant amount of MPC5xx support as part of the addition of the SS555 BSP. * mpc5xx/README, mpc5xx/clock/clock.c, mpc5xx/console-generic/console-generic.c, mpc5xx/include/console.h, mpc5xx/include/mpc5xx.h, mpc5xx/irq/irq.c, mpc5xx/irq/irq.h, mpc5xx/irq/irq_asm.S, mpc5xx/irq/irq_init.c, mpc5xx/vectors/vectors.S, mpc5xx/vectors/vectors.h, mpc5xx/vectors/vectors_init.c: New files. * mpc5xx/exceptions/asm_utils.S: Removed.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/powerpc/configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/c/src/lib/libcpu/powerpc/configure.ac b/c/src/lib/libcpu/powerpc/configure.ac
index d581ad3eb5..bd895db149 100644
--- a/c/src/lib/libcpu/powerpc/configure.ac
+++ b/c/src/lib/libcpu/powerpc/configure.ac
@@ -22,9 +22,10 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_PROG_CCAS
AM_CONDITIONAL(shared, \
-test "$RTEMS_CPU_MODEL" = "mpc5xx" \
-|| test "$RTEMS_CPU_MODEL" = "mpc750" \
+ test "$RTEMS_CPU_MODEL" = "mpc750" \
|| test "$RTEMS_CPU_MODEL" = "mpc7400" \
+|| test "$RTEMS_CPU_MODEL" = "mpc555" \
+|| test "$RTEMS_CPU_MODEL" = "mpc5xx" \
|| test "$RTEMS_CPU_MODEL" = "ppc603e" \
|| test "$RTEMS_CPU_MODEL" = "mpc604" \
|| test "$RTEMS_CPU_MODEL" = "mpc6xx" \
@@ -35,7 +36,8 @@ test "$RTEMS_CPU_MODEL" = "mpc5xx" \
## test on CPU type
AM_CONDITIONAL(mpc505, test "$RTEMS_CPU_MODEL" = "mpc505")
-AM_CONDITIONAL(mpc5xx, test "$RTEMS_CPU_MODEL" = "mpc5xx")
+AM_CONDITIONAL(mpc5xx, test "$RTEMS_CPU_MODEL" = "mpc5xx" \
+|| test "$RTEMS_CPU_MODEL" = "mpc555" )
AM_CONDITIONAL(mpc6xx, test "$RTEMS_CPU_MODEL" = "mpc6xx" \
|| test "$RTEMS_CPU_MODEL" = "mpc604" \
|| test "$RTEMS_CPU_MODEL" = "mpc7400" \