summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/powerpc/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 02:21:47 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-12 02:21:47 +0000
commit20ad4755673f692936cd07774c5ceedc452dce98 (patch)
tree2970519a8b878e0504bf48e417f7c820c355f5f6 /c/src/lib/libcpu/powerpc/configure.ac
parent2005-02-11 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-20ad4755673f692936cd07774c5ceedc452dce98.tar.bz2
2005-02-11 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: subdir-objects. Add compiler check for old/new-style exception processing.
Diffstat (limited to 'c/src/lib/libcpu/powerpc/configure.ac')
-rw-r--r--c/src/lib/libcpu/powerpc/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/powerpc/configure.ac b/c/src/lib/libcpu/powerpc/configure.ac
index 05fe819190..0a80717077 100644
--- a/c/src/lib/libcpu/powerpc/configure.ac
+++ b/c/src/lib/libcpu/powerpc/configure.ac
@@ -9,7 +9,7 @@ RTEMS_TOP([../../../../..],[../../..])
RTEMS_CANONICAL_TARGET_CPU
-AM_INIT_AUTOMAKE([no-define foreign 1.9])
+AM_INIT_AUTOMAKE([no-define foreign subdir-objects 1.9])
AM_MAINTAINER_MODE
RTEMS_ENV_RTEMSBSP
@@ -17,9 +17,22 @@ RTEMS_ENV_RTEMSBSP
RTEMS_PROJECT_ROOT
RTEMS_PROG_CC_FOR_TARGET
+AM_PROG_CC_C_O
RTEMS_CANONICALIZE_TOOLS
RTEMS_PROG_CCAS
+AC_MSG_CHECKING([for style of powerpc exceptions])
+AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM(
+ [],
+ [#if defined(_OLD_EXCEPTIONS)
+ choke me
+ #endif])],
+ [EXCEPTIONS=new],
+ [EXCEPTIONS=old])
+AC_MSG_RESULT([$EXCEPTIONS])
+AM_CONDITIONAL([OLD_EXCEPTIONS],[test "$EXCEPTIONS" = old])
+
AM_CONDITIONAL(shared, \
test "$RTEMS_CPU_MODEL" = "mpc750" \
|| test "$RTEMS_CPU_MODEL" = "mpc7400" \