summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/or1k/Makefile.am
diff options
context:
space:
mode:
authorHesham ALMatary <heshamelmatary@gmail.com>2014-09-16 12:30:46 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-09-16 12:46:42 -0500
commitc080c3434b9e4911078e40a697ec1f5d01b6cf24 (patch)
tree41f8725edb497483ce1cc45c76b9010881a5a09c /c/src/lib/libcpu/or1k/Makefile.am
parentor1ksim: Update README (diff)
downloadrtems-c080c3434b9e4911078e40a697ec1f5d01b6cf24.tar.bz2
or1k: New cache manager.
Implement new cache functions for or1k and create new bspstart function for or1ksim to initialize instruction and data caches. Also, sim.cfg is modified to enable/confiure cache units.
Diffstat (limited to 'c/src/lib/libcpu/or1k/Makefile.am')
-rw-r--r--c/src/lib/libcpu/or1k/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/or1k/Makefile.am b/c/src/lib/libcpu/or1k/Makefile.am
index f4a637216d..8971f4d65b 100644
--- a/c/src/lib/libcpu/or1k/Makefile.am
+++ b/c/src/lib/libcpu/or1k/Makefile.am
@@ -10,8 +10,9 @@ include_libcpudir = $(includedir)/libcpu
## shared/cache
include_libcpu_HEADERS = ../shared/include/cache.h
+include_libcpu_HEADERS += shared/cache/cache_.h
noinst_PROGRAMS += shared/cache.rel
-shared_cache_rel_SOURCES = ../shared/src/no_cache.c shared/cache/cache_.h
+shared_cache_rel_SOURCES = shared/cache/cache.c ../shared/src/cache_manager.c
shared_cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/shared/cache
shared_cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)