summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/r46xx/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:35:07 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-02 12:35:07 +0000
commitc8db773dfaee652fc8e1e9be30349aacbe68c154 (patch)
tree2d45756c9493d696038a98691a273b378c1f5bab /c/src/lib/libcpu/mips/r46xx/Makefile.am
parent2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-c8db773dfaee652fc8e1e9be30349aacbe68c154.tar.bz2
2005-01-02 Ralf Corsepius <ralf.corsepius@rtems.org>
* mongoosev/Makefile.am, r46xx/Makefile.am, shared/Makefile.am, tx39/Makefile.am: Remove build-variant support.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/mips/r46xx/Makefile.am37
1 files changed, 4 insertions, 33 deletions
diff --git a/c/src/lib/libcpu/mips/r46xx/Makefile.am b/c/src/lib/libcpu/mips/r46xx/Makefile.am
index 2aa557673c..0449d4703a 100644
--- a/c/src/lib/libcpu/mips/r46xx/Makefile.am
+++ b/c/src/lib/libcpu/mips/r46xx/Makefile.am
@@ -2,58 +2,29 @@
## $Id$
##
-EXTRA_PROGRAMS =
-CLEANFILES =
-noinst_DATA =
+noinst_PROGRAMS =
include $(top_srcdir)/../../../automake/compile.am
if r46xx
-EXTRA_PROGRAMS += vectorisrs.rel
-CLEANFILES += vectorisrs.rel
+noinst_PROGRAMS += vectorisrs.rel
vectorisrs_rel_SOURCES = vectorisrs/maxvectors.c vectorisrs/vectorisrs.c
vectorisrs_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
vectorisrs_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += vectorisrs_g.rel
-CLEANFILES += vectorisrs_g.rel
-vectorisrs_g_rel_SOURCES = $(vectorisrs_rel_SOURCES)
-vectorisrs_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-vectorisrs_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += vectorisrs$(LIB_VARIANT).rel
endif
if r46xx
-EXTRA_PROGRAMS += timer.rel
-CLEANFILES += timer.rel
+noinst_PROGRAMS += timer.rel
timer_rel_SOURCES = ../timer/timer.c ../timer/gettime.S
timer_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += timer_g.rel
-CLEANFILES += timer_g.rel
-timer_g_rel_SOURCES = $(timer_rel_SOURCES)
-timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += timer$(LIB_VARIANT).rel
endif
if r46xx
-EXTRA_PROGRAMS += clock.rel
-CLEANFILES += clock.rel
+noinst_PROGRAMS += clock.rel
clock_rel_SOURCES = ../clock/ckinit.c ../clock/clock.S ../clock/clock.h
clock_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-EXTRA_PROGRAMS += clock_g.rel
-CLEANFILES += clock_g.rel
-clock_g_rel_SOURCES = $(clock_rel_SOURCES)
-clock_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
-clock_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_DATA += clock$(LIB_VARIANT).rel
endif
include $(top_srcdir)/../../../automake/local.am