summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/r46xx/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-21 06:50:10 +0000
commit63ae87612da91339a32ceecd218546a469d45b4a (patch)
tree9c8cfd43b9a367cbc4e5f8fe86071014afe64911 /c/src/lib/libcpu/mips/r46xx/Makefile.am
parent2003-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-63ae87612da91339a32ceecd218546a469d45b4a.tar.bz2
2004-01-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* clock/Makefile.am, timer/Makefile.am: Remove. * r46xx/Makefile.am: Built timer.rel, clock.rel. Add PREINSTALL_DIRS. * Makefile.am: Remove timer, clock. * tx39/Makefile.am, mongoosev/Makefile.am, shared/Makefile.am: Add PREINSTALL_DIRS. * configure.ac: Reflect removing clock/Makefile.am, timer/Makefile.am. Add subdir-objects to AUTOMAKE_OPTIONS.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/mips/r46xx/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/mips/r46xx/Makefile.am b/c/src/lib/libcpu/mips/r46xx/Makefile.am
index ef846f03d2..c91d14250d 100644
--- a/c/src/lib/libcpu/mips/r46xx/Makefile.am
+++ b/c/src/lib/libcpu/mips/r46xx/Makefile.am
@@ -27,4 +27,36 @@ vectorisrs_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
noinst_DATA += vectorisrs$(LIB_VARIANT).rel
endif
+if r46xx
+EXTRA_PROGRAMS += timer.rel
+CLEANFILES += timer.rel
+timer_rel_SOURCES = ../timer/timer.c ../timer/gettime.S
+timer_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += timer_g.rel
+CLEANFILES += timer_g.rel
+timer_g_rel_SOURCES = $(timer_rel_SOURCES)
+timer_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+timer_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += timer$(LIB_VARIANT).rel
+endif
+
+if r46xx
+EXTRA_PROGRAMS += clock.rel
+CLEANFILES += clock.rel
+clock_rel_SOURCES = ../clock/ckinit.c ../clock/clock.S ../clock/clock.h
+clock_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+EXTRA_PROGRAMS += clock_g.rel
+CLEANFILES += clock_g.rel
+clock_g_rel_SOURCES = $(clock_rel_SOURCES)
+clock_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+clock_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+
+noinst_DATA += clock$(LIB_VARIANT).rel
+endif
+
include $(top_srcdir)/../../../automake/local.am