summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 21:52:19 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-10-24 21:52:19 +0000
commit5b53d9700d67534bffa38c1af981b79469d19616 (patch)
treedde0d583b37360405047727193d07cc7000068e9 /c/src/lib/libcpu/mips/configure.in
parent2000-10-24 Alan Cudmore <alanc@linuxstart.com> and (diff)
downloadrtems-5b53d9700d67534bffa38c1af981b79469d19616.tar.bz2
2000-10-24 Alan Cudmore <alanc@linuxstart.com> and
Joel Sherrill <joel@OARcorp.com> * This is a major reworking of the mips64orion port to use gcc predefines as much as possible and a big push to multilib the mips port. The mips64orion port was copied/renamed to mips to be more like other GNU tools. Alan did most of the technical work of determining how to map old macro names used by the mips64orion port to standard compiler macro definitions. Joel did the merge with CVS magic to keep individual file history and did the BSP modifications. Details follow: * Makefile.am: Made clock and timer subdirectories conditional. * configure.in: Ditto. * clock/clock.S: Switch from using <idtmon.h> to <asm.h>. * clock/gettime.S: Switch from using <idtmon.h> to <asm.h>.
Diffstat (limited to 'c/src/lib/libcpu/mips/configure.in')
-rw-r--r--c/src/lib/libcpu/mips/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/mips/configure.in b/c/src/lib/libcpu/mips/configure.in
index aed970845c..822592cdc0 100644
--- a/c/src/lib/libcpu/mips/configure.in
+++ b/c/src/lib/libcpu/mips/configure.in
@@ -9,7 +9,7 @@ AC_CONFIG_AUX_DIR(../../../../..)
RTEMS_CANONICAL_TARGET_CPU
-AM_INIT_AUTOMAKE(rtems-c-src-lib-libcpu-mips64orion,$RTEMS_VERSION,no)
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libcpu-mips,$RTEMS_VERSION,no)
AM_MAINTAINER_MODE
RTEMS_ENABLE_BARE
@@ -26,6 +26,9 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+AM_CONDITIONAL(r46xx, test "$RTEMS_CPU_MODEL" = "R4600" \
+|| test "$RTEMS_CPU_MODEL" = "R4650" )
+
# Explicitly list all Makefiles here
AC_OUTPUT(
Makefile