summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/mips/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-12 18:09:13 -0500
committerJoel Sherrill <joel.sherrill@oarcorp.com>2014-10-13 10:32:38 -0500
commitf95f212af448db2bbd50cda81bbe961317b18201 (patch)
treee8ad61572793bcaeee0c3ab8dafc9d4408b0a127 /c/src/lib/libcpu/mips/Makefile.am
parentmips/clock/ckinit.c: Clean up (may be unused) (diff)
downloadrtems-f95f212af448db2bbd50cda81bbe961317b18201.tar.bz2
Remove libcpu/mips/clock - unused code
This code was only referenced for r46xx CPU models. There are no BSPs currently in the tree with this CPU model. The r46xx was the original target for the MIPS port and it is likely that the code has not been used on actual hardware in many years. All MIPS BSPs successfully built after this was removed.
Diffstat (limited to 'c/src/lib/libcpu/mips/Makefile.am')
-rw-r--r--c/src/lib/libcpu/mips/Makefile.am12
1 files changed, 0 insertions, 12 deletions
diff --git a/c/src/lib/libcpu/mips/Makefile.am b/c/src/lib/libcpu/mips/Makefile.am
index e4dd7caf33..be4d2c0df7 100644
--- a/c/src/lib/libcpu/mips/Makefile.am
+++ b/c/src/lib/libcpu/mips/Makefile.am
@@ -56,18 +56,6 @@ include_libcpu_HEADERS += au1x00/include/au1x00.h
endif
-if r46xx
-noinst_PROGRAMS += r46xx/timer.rel
-r46xx_timer_rel_SOURCES = timer/timer.c timer/gettime.S
-r46xx_timer_rel_CPPFLAGS = $(AM_CPPFLAGS)
-r46xx_timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-
-noinst_PROGRAMS += r46xx/clock.rel
-r46xx_clock_rel_SOURCES = clock/ckinit.c clock/clock.S clock/clock.h
-r46xx_clock_rel_CPPFLAGS = $(AM_CPPFLAGS)
-r46xx_clock_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-endif
-
if rm52xx
include_libcpu_HEADERS += rm52xx/include/rm5231.h