summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/m68k/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-19 15:51:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-19 15:51:33 +0000
commitc01e72bdc519753b96da89248efde5126f4f3da2 (patch)
tree4c4616e634e69890ff619cb87d21e55bed391b8f /c/src/lib/libcpu/m68k/Makefile.am
parent2008-09-19 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-c01e72bdc519753b96da89248efde5126f4f3da2.tar.bz2
2008-09-19 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am: Split out various BSPs bspstart.c contents. Move cache management code here. * mcf5223x/cache/cachepd.c, mcf5235/cache/cachepd.c: New files.
Diffstat (limited to 'c/src/lib/libcpu/m68k/Makefile.am')
-rw-r--r--c/src/lib/libcpu/m68k/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/m68k/Makefile.am b/c/src/lib/libcpu/m68k/Makefile.am
index cbdcd7e919..ee36288c4d 100644
--- a/c/src/lib/libcpu/m68k/Makefile.am
+++ b/c/src/lib/libcpu/m68k/Makefile.am
@@ -97,12 +97,24 @@ if mcf5223x
## mcf5223x/include
include_mcf5223xdir = $(includedir)/mcf5223x
include_mcf5223x_HEADERS = mcf5223x/include/mcf5223x.h
+
+## mcf5223x/cache
+noinst_PROGRAMS += mcf5223x/cachepd.rel
+mcf5223x_cachepd_rel_SOURCES = mcf5223x/cache/cachepd.c
+mcf5223x_cachepd_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mcf5223x_cachepd_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
if mcf5235
## mcf5235/include
include_mcf5235dir = $(includedir)/mcf5235
include_mcf5235_HEADERS = mcf5235/include/mcf5235.h
+
+## mcf5235/cache
+noinst_PROGRAMS += mcf5235/cachepd.rel
+mcf5235_cachepd_rel_SOURCES = mcf5235/cache/cachepd.c
+mcf5235_cachepd_rel_CPPFLAGS = $(AM_CPPFLAGS)
+mcf5235_cachepd_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
if mcf532x