summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/i386/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 14:58:13 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-11-25 16:08:16 +0100
commit7e5c9b895e52c76376386e54a0008c3a9e4a1698 (patch)
treebb8f7db25258fc1438c58a60aa950d782d0d77ab /c/src/lib/libcpu/i386/Makefile.am
parentsptest/spcache01: New test cases (diff)
downloadrtems-7e5c9b895e52c76376386e54a0008c3a9e4a1698.tar.bz2
rtems: Move rtems_cache_aligned_malloc()
Make sure also the size is cache aligned since otherwise we may have some overlap with the next allocation block. A cache invalidate on this area would be fatal.
Diffstat (limited to 'c/src/lib/libcpu/i386/Makefile.am')
-rw-r--r--c/src/lib/libcpu/i386/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/c/src/lib/libcpu/i386/Makefile.am b/c/src/lib/libcpu/i386/Makefile.am
index 0330ba31ef..0869435025 100644
--- a/c/src/lib/libcpu/i386/Makefile.am
+++ b/c/src/lib/libcpu/i386/Makefile.am
@@ -11,7 +11,7 @@ include_libcpu_HEADERS += ../shared/include/cache.h
include_libcpu_HEADERS += byteorder.h
noinst_PROGRAMS += cache.rel
-cache_rel_SOURCES = cache.c cache_.h ../shared/src/cache_aligned_malloc.c \
+cache_rel_SOURCES = cache.c cache_.h \
../shared/src/cache_manager.c ../shared/include/cache.h
cache_rel_CPPFLAGS = $(AM_CPPFLAGS)
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)