summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/hppa1.1/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-03-05 22:46:48 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-03-05 22:46:48 +0000
commit5ce7c34994e860249cc7a5af5a10fde8d6a18eff (patch)
treeccfbccafcaf239207e69caa95d471bb240a54ece /c/src/lib/libcpu/hppa1.1/include/Makefile.am
parent2001-03-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-5ce7c34994e860249cc7a5af5a10fde8d6a18eff.tar.bz2
2001-02-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de:
* include/Makefile.am: Apply include_*HEADERS instead of H_FILES.
Diffstat (limited to 'c/src/lib/libcpu/hppa1.1/include/Makefile.am')
-rw-r--r--c/src/lib/libcpu/hppa1.1/include/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/lib/libcpu/hppa1.1/include/Makefile.am b/c/src/lib/libcpu/hppa1.1/include/Makefile.am
index 43044008c5..ded92219d4 100644
--- a/c/src/lib/libcpu/hppa1.1/include/Makefile.am
+++ b/c/src/lib/libcpu/hppa1.1/include/Makefile.am
@@ -4,7 +4,9 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = runway.h semaphore.h
+include_hppa1_1dir = $(includedir)/hppa1.1
+
+include_hppa1_1_HEADERS = runway.h semaphore.h
# NOTE: Unlike other CPUS, we install into a subdirectory to avoid
# file name conflicts
@@ -16,7 +18,7 @@ $(PROJECT_INCLUDE)/hppa1.1/%.h: %.h
$(INSTALL_DATA) $< $@
PREINSTALL_FILES += $(PROJECT_INCLUDE)/hppa1.1 \
- $(H_FILES:%.h=$(PROJECT_INCLUDE)/hppa1.1/%.h)
+ $(include_hppa1_1_HEADERS:%=$(PROJECT_INCLUDE)/hppa1.1/%)
all-local: $(TMPINSTALL_FILES)