summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/bfin/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2017-12-23 18:18:56 +1100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-01-25 08:45:26 +0100
commit2afb22b7e1ebcbe40373ff7e0efae7d207c655a9 (patch)
tree44759efe9374f13200a97e96d91bd9a2b7e5ce2a /c/src/lib/libcpu/bfin/Makefile.am
parentMAINTAINERS: Add myself to Write After Approval. (diff)
downloadrtems-2afb22b7e1ebcbe40373ff7e0efae7d207c655a9.tar.bz2
Remove make preinstall
A speciality of the RTEMS build system was the make preinstall step. It copied header files from arbitrary locations into the build tree. The header files were included via the -Bsome/build/tree/path GCC command line option. This has at least seven problems: * The make preinstall step itself needs time and disk space. * Errors in header files show up in the build tree copy. This makes it hard for editors to open the right file to fix the error. * There is no clear relationship between source and build tree header files. This makes an audit of the build process difficult. * The visibility of all header files in the build tree makes it difficult to enforce API barriers. For example it is discouraged to use BSP-specifics in the cpukit. * An introduction of a new build system is difficult. * Include paths specified by the -B option are system headers. This may suppress warnings. * The parallel build had sporadic failures on some hosts. This patch removes the make preinstall step. All installed header files are moved to dedicated include directories in the source tree. Let @RTEMS_CPU@ be the target architecture, e.g. arm, powerpc, sparc, etc. Let @RTEMS_BSP_FAMILIY@ be a BSP family base directory, e.g. erc32, imx, qoriq, etc. The new cpukit include directories are: * cpukit/include * cpukit/score/cpu/@RTEMS_CPU@/include * cpukit/libnetworking The new BSP include directories are: * bsps/include * bsps/@RTEMS_CPU@/include * bsps/@RTEMS_CPU@/@RTEMS_BSP_FAMILIY@/include There are build tree include directories for generated files. The include directory order favours the most general header file, e.g. it is not possible to override general header files via the include path order. The "bootstrap -p" option was removed. The new "bootstrap -H" option should be used to regenerate the "headers.am" files. Update #3254.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libcpu/bfin/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/c/src/lib/libcpu/bfin/Makefile.am b/c/src/lib/libcpu/bfin/Makefile.am
index 1dc90d481b..5f981657f7 100644
--- a/c/src/lib/libcpu/bfin/Makefile.am
+++ b/c/src/lib/libcpu/bfin/Makefile.am
@@ -6,21 +6,12 @@ EXTRA_DIST =
noinst_PROGRAMS =
-include_bspdir = $(includedir)/bsp
-include_libcpudir = $(includedir)/libcpu
-
-include_bsp_HEADERS =
-include_libcpu_HEADERS =
-
############
# Start of bf52x files
if bf52x
-include_HEADERS = bf52x/include/bf52x.h
-
## INTERRUPT
-include_bsp_HEADERS += bf52x/interrupt/interrupt.h
noinst_PROGRAMS += bf52x/interrupt.rel
bf52x_interrupt_rel_SOURCES = bf52x/interrupt/interrupt.c \
bf52x/interrupt/interrupt.h
@@ -31,33 +22,12 @@ endif
# endof bf52x
############
-include_libcpu_HEADERS += include/bf533.h
-include_libcpu_HEADERS += include/bf537.h
-include_libcpu_HEADERS += include/cecRegs.h
-include_libcpu_HEADERS += include/memoryRegs.h
-include_libcpu_HEADERS += include/mmuRegs.h
-include_libcpu_HEADERS += include/sicRegs.h
-include_libcpu_HEADERS += include/ebiuRegs.h
-include_libcpu_HEADERS += include/ppiRegs.h
-include_libcpu_HEADERS += include/coreTimerRegs.h
-include_libcpu_HEADERS += include/wdogRegs.h
-include_libcpu_HEADERS += include/timerRegs.h
-include_libcpu_HEADERS += include/dmaRegs.h
-include_libcpu_HEADERS += include/ethernetRegs.h
-include_libcpu_HEADERS += include/uartRegs.h
-include_libcpu_HEADERS += include/sportRegs.h
-include_libcpu_HEADERS += include/twiRegs.h
-include_libcpu_HEADERS += include/spiRegs.h
-include_libcpu_HEADERS += include/rtcRegs.h
-include_libcpu_HEADERS += include/gpioRegs.h
-
noinst_PROGRAMS += cache.rel
cache_rel_SOURCES = cache/cache.c \
../shared/src/cache_manager.c cache/cache_.h
cache_rel_CPPFLAGS = $(AM_CPPFLAGS) -I$(srcdir)/cache
cache_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += mmu/mmu.h
noinst_PROGRAMS += mmu.rel
mmu_rel_SOURCES = mmu/mmu.c
mmu_rel_CPPFLAGS = $(AM_CPPFLAGS)
@@ -66,7 +36,6 @@ mmu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
if bf52x
else
-include_libcpu_HEADERS += interrupt/interrupt.h
noinst_PROGRAMS += interrupt.rel
interrupt_rel_SOURCES = interrupt/interrupt.c
interrupt_rel_CPPFLAGS = $(AM_CPPFLAGS)
@@ -84,25 +53,21 @@ rtc_rel_SOURCES = clock/rtc.c clock/rtc.h
rtc_rel_CPPFLAGS = $(AM_CPPFLAGS)
rtc_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += serial/uart.h
noinst_PROGRAMS += uart.rel
uart_rel_SOURCES = serial/uart.c
uart_rel_CPPFLAGS = $(AM_CPPFLAGS)
uart_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += serial/sport.h
noinst_PROGRAMS += sport.rel
sport_rel_SOURCES = serial/sport.c
sport_rel_CPPFLAGS = $(AM_CPPFLAGS)
sport_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += serial/spi.h
noinst_PROGRAMS += spi.rel
spi_rel_SOURCES = serial/spi.c
spi_rel_CPPFLAGS = $(AM_CPPFLAGS)
spi_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-include_libcpu_HEADERS += serial/twi.h
noinst_PROGRAMS += twi.rel
twi_rel_SOURCES = serial/twi.c
twi_rel_CPPFLAGS = $(AM_CPPFLAGS)
@@ -115,7 +80,6 @@ timer_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
if HAS_NETWORKING
## network
-include_libcpu_HEADERS += network/ethernet.h
network_CPPFLAGS = -D__INSIDE_RTEMS_BSD_TCPIP_STACK__
noinst_PROGRAMS += network.rel
network_rel_SOURCES = network/ethernet.c
@@ -123,5 +87,4 @@ network_rel_CPPFLAGS = $(AM_CPPFLAGS) $(network_CPPFLAGS)
network_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
endif
-include $(srcdir)/preinstall.am
include $(top_srcdir)/../../../automake/local.am