summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libcpu/a29k/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 14:20:08 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-26 14:20:08 +0000
commit21677c0e664f84ac20ffec33209348c52d00aace (patch)
treec6d3531ac6aec1613d6b2f844db4f91bb6fa56ed /c/src/lib/libcpu/a29k/configure.in
parentNow binutils, gcc, and gdb build into a "base" package that is shared (diff)
downloadrtems-21677c0e664f84ac20ffec33209348c52d00aace.tar.bz2
Patch rtems-rc-20000118-0.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the a29k to automake. This patch contains * An initial merger of the libcpu/a29k stuff you sent yesterday. AFAIS, most code inside them seems to be empty stubs. One file even contains a function called mips_*** which might indicate that this part might contain mips code or the code the initial porter used as template for porting. Unfortunately, I don't know anything about the a29k so I can't comment on the details. * A dummy bsp_specs to libbsp/29k/portsw * An update to the automake files related to the a29k. Note: * This patch is completely untested, because I don't have a toolchain for it. * The files in libcpu/a29k include bsp.h => The libbsp vs. libcpu-issue hits again.
Diffstat (limited to 'c/src/lib/libcpu/a29k/configure.in')
-rw-r--r--c/src/lib/libcpu/a29k/configure.in35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/lib/libcpu/a29k/configure.in b/c/src/lib/libcpu/a29k/configure.in
new file mode 100644
index 0000000000..dabe68edb9
--- /dev/null
+++ b/c/src/lib/libcpu/a29k/configure.in
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(clock)
+RTEMS_TOP(../../../../..)
+AC_CONFIG_AUX_DIR(../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libcpu-a29k,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENABLE_BARE
+RTEMS_ENV_RTEMSBSP
+
+RTEMS_CHECK_CPU
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+dnl check target cc
+RTEMS_PROG_CC_FOR_TARGET
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+
+AC_OUTPUT(
+Makefile
+clock/Makefile
+timer/Makefile)