summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/x86_64/configure.ac
diff options
context:
space:
mode:
authorAmaan Cheval <amaan.cheval@gmail.com>2018-07-09 16:42:56 +0530
committerJoel Sherrill <joel@rtems.org>2018-07-11 15:22:44 -0500
commit76c03152e110dcb770253b54277811228e8f78df (patch)
tree961fe157e59b137d932c4feb7d275b6157f99da0 /c/src/lib/libbsp/x86_64/configure.ac
parentbsp/riscv: Add console support for NS16550 devices (diff)
downloadrtems-76c03152e110dcb770253b54277811228e8f78df.tar.bz2
bsp/x86_64: Minimal bootable BSP
Current state: - Basic context initialization and switching code. - Stubbed console (empty functions). - Mostly functional linker script (may need tweaks if we ever want to move away from the large code model (see: CPU_CFLAGS). - Fully functional boot, by using FreeBSD's bootloader to load RTEMS's ELF for UEFI-awareness. In short, the current state with this commit lets us boot, go through the system initialization functions, and then call user application's Init task too. Updates #2898.
Diffstat (limited to 'c/src/lib/libbsp/x86_64/configure.ac')
-rw-r--r--c/src/lib/libbsp/x86_64/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/x86_64/configure.ac b/c/src/lib/libbsp/x86_64/configure.ac
new file mode 100644
index 0000000000..a398a4e202
--- /dev/null
+++ b/c/src/lib/libbsp/x86_64/configure.ac
@@ -0,0 +1,20 @@
+## Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
+AC_INIT([rtems-c-src-lib-libbsp-x86_64],[_RTEMS_VERSION],[https://devel.rtems.org/newticket])
+RTEMS_TOP(../../../../..)
+RTEMS_SOURCE_TOP
+RTEMS_BUILD_TOP
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE([no-define foreign subdir-objects 1.12.2])
+AM_MAINTAINER_MODE
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_PROJECT_ROOT
+
+RTEMS_CHECK_BSPDIR([$RTEMS_BSP_FAMILY])
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT