summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/posix/tools/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
commitdf49c60c9671e4a28e636964d744c1f59fb6cb68 (patch)
treeeabd85e189514ad412a35414ba5d483dcda3ef1f /c/src/lib/libbsp/unix/posix/tools/Makefile.am
parentPurged as many egcs references as possible. (diff)
downloadrtems-df49c60c9671e4a28e636964d744c1f59fb6cb68.tar.bz2
Merged from 4.5.0-beta3a
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/unix/posix/tools/Makefile.am30
1 files changed, 23 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/unix/posix/tools/Makefile.am b/c/src/lib/libbsp/unix/posix/tools/Makefile.am
index 63929b60fc..6b498aa16a 100644
--- a/c/src/lib/libbsp/unix/posix/tools/Makefile.am
+++ b/c/src/lib/libbsp/unix/posix/tools/Makefile.am
@@ -7,15 +7,31 @@ ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
if PERL
perl_scripts = shmdump semdump
+PERL_TMPINSTALL_FILES = $(PROJECT_ROOT)/posix/tests/shmdump \
+ $(PROJECT_ROOT)/posix/tests/semdump
endif
-noinst_SCRIPTS=runtest looptest $(perl_scripts)
+noinst_SCRIPTS = runtest looptest $(perl_scripts)
+
+$(PROJECT_ROOT)/posix/tests:
+ $(mkinstalldirs) $@
+
+$(PROJECT_ROOT)/posix/tests/runtest: runtest
+ $(INSTALL_SCRIPT) $< $@
+
+$(PROJECT_ROOT)/posix/tests/looptest: looptest
+ $(INSTALL_SCRIPT) $< $@
+
+$(PROJECT_ROOT)/posix/tests/shmdump: shmdump
+ $(INSTALL_SCRIPT) $< $@
+
+$(PROJECT_ROOT)/posix/tests/semdump: semdump
+ $(INSTALL_SCRIPT) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_ROOT)/posix/tests \
+ $(PROJECT_ROOT)/posix/tests/runtest $(PROJECT_ROOT)/posix/tests/looptest
## HACK: install to build-tree
-all-local: $(SCRIPTS)
- $(mkinstalldirs) $(PROJECT_ROOT)/posix/tests
- for i in $(SCRIPTS); do \
- $(INSTALL_SCRIPT) $$i $(PROJECT_ROOT)/posix/tests ; \
- done
+all-local: $(TMPINSTALL_FILES) $(PERL_TMPINSTALL_FILES)
-include $(top_srcdir)/../../../../../../../automake/local.am
+include $(top_srcdir)/../../../../../../../automake/host.am