summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/unix/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:03:32 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 14:03:32 +0000
commit49e05f41316997008b8af1bb76f6878532246f50 (patch)
tree600513900ecf14f6cc4fe6ece9607eba79f4b3a6 /c/src/lib/libbsp/unix/configure.in
parentPatch rtems-rc-20000104-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-49e05f41316997008b8af1bb76f6878532246f50.tar.bz2
Patch rtems-rc-20000104-4.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the unix directory to automake. Ralf's note: Please check c/src/lib/libbsp/unix/posix/startup/Makefile.am. I am not sure if it is correct.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/unix/configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/unix/configure.in b/c/src/lib/libbsp/unix/configure.in
new file mode 100644
index 0000000000..cd6ad2a797
--- /dev/null
+++ b/c/src/lib/libbsp/unix/configure.in
@@ -0,0 +1,26 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(posix)
+RTEMS_TOP(../../../../..)
+AC_CONFIG_AUX_DIR(../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-unix,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_PROJECT_ROOT
+
+RTEMS_BSP_ALIAS(${RTEMS_BSP},bspdir)
+AC_CONFIG_SUBDIRS($bspdir)
+
+# try to explicitly list a Makefile here
+AC_OUTPUT(
+Makefile)