summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2005-10-05 19:26:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2005-10-05 19:26:00 +0000
commit1348869fbbd654c3a5f372d1dd007b701c315aa9 (patch)
treeb628299be00bf754eb57b9df6025fcf5659ec0dd /c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am
parent2005-10-05 Jiri Gaisler <jiri@gaisler.com> (diff)
downloadrtems-1348869fbbd654c3a5f372d1dd007b701c315aa9.tar.bz2
2005-10-05 Jiri Gaisler <jiri@gaisler.com>
Edvin Catovic <edvin@gaisler.com> Konrad Eisele <konrad@gaisler.com> PR 827/bsps * .cvsignore, ChangeLog, Makefile.am, README, bsp_specs, configure.ac, times, amba/.cvsignore, amba/Makefile.am, amba/amba.c, clock/.cvsignore, clock/Makefile.am, clock/ckinit.c, console/.cvsignore, console/Makefile.am, console/console.c, console/consolereserveresources.c, console/debugputs.c, gnatsupp/.cvsignore, gnatsupp/Makefile.am, gnatsupp/gnatsupp.c, include/.cvsignore, include/Makefile.am, include/amba.h, include/bsp.h, include/coverhd.h, include/leon.h, leon_open_eth/.cvsignore, leon_open_eth/Makefile.am, leon_open_eth/leon_open_eth.c, leon_smc91111/.cvsignore, leon_smc91111/Makefile.am, leon_smc91111/leon_smc91111.c, start/.cvsignore, start/Makefile.am, startup/.cvsignore, startup/Makefile.am, startup/bspstart.c, startup/ithread.S, startup/linkcmds, startup/setvec.c, startup/spurious.c, timer/.cvsignore, timer/Makefile.am, timer/timer.c, tools/.cvsignore, tools/ChangeLog, tools/Makefile.am, tools/configure.ac, tools/runtest.in, wrapup/.cvsignore, wrapup/Makefile.am: New files.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am b/c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am
new file mode 100644
index 0000000000..515a76e7cc
--- /dev/null
+++ b/c/src/lib/libbsp/sparc/leon3/wrapup/Makefile.am
@@ -0,0 +1,31 @@
+##
+## $Id$
+##
+
+# We only build the networking device driver if HAS_NETWORKING was defined
+if HAS_NETWORKING
+NETWORKING_DRIVER = leon_open_eth leon_smc91111
+endif
+
+BSP_PIECES = startup amba console clock timer gnatsupp $(NETWORKING_DRIVER)
+# pieces to pick up out of libcpu/sparc
+CPU_PIECES = cache reg_win syscall
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(BSP_PIECES), $(wildcard ../$(piece)/$(ARCH)/*.$(OBJEXT))) \
+ $(foreach piece, $(CPU_PIECES), ../../../../libcpu/$(RTEMS_CPU)/$(piece)/$(ARCH)/*.$(OBJEXT))
+LIB = $(ARCH)/libbsp.a
+
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+all-local: $(ARCH) $(LIB)
+
+include $(top_srcdir)/../../../../../../automake/local.am