summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2013-11-25 08:46:19 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-02-06 08:47:03 +0100
commit7579e255127ee0cf04901bbab6c1538559053508 (patch)
tree197204842c354c82c5fdce975e4dd6051545a41c /c/src/lib/libbsp/sparc/leon3/configure.ac
parentbsp/leon3: Declare bsp_debug_uart_init() in header (diff)
downloadrtems-7579e255127ee0cf04901bbab6c1538559053508.tar.bz2
bsp/leon3: New BSP variant leon3_qemu
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/configure.ac')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/configure.ac b/c/src/lib/libbsp/sparc/leon3/configure.ac
index dbefd3e8f2..e22f69a00e 100644
--- a/c/src/lib/libbsp/sparc/leon3/configure.ac
+++ b/c/src/lib/libbsp/sparc/leon3/configure.ac
@@ -26,6 +26,7 @@ RTEMS_BSPOPTS_HELP([CONSOLE_USE_INTERRUPTS],
Under the simulator (especially when FAST_UART is defined), polled seems to operate
better.])
+RTEMS_BSPOPTS_SET([SIMSPARC_FAST_IDLE],[*qemu],[1])
RTEMS_BSPOPTS_SET([SIMSPARC_FAST_IDLE],[*],[])
RTEMS_BSPOPTS_HELP([SIMSPARC_FAST_IDLE],
[If defined, speed up the clock ticks while the idle task is running so
@@ -37,6 +38,10 @@ RTEMS_BSPOPTS_HELP([BSP_LEON3_SMP],
[Always defined when on a LEON3 to enable the LEON3 support for
determining the CPU core number in an SMP configuration.])
+RTEMS_BSPOPTS_SET([LEON3_QEMU],[*qemu],[1])
+RTEMS_BSPOPTS_HELP([LEON3_QEMU],
+[If defined, then use settings for QEMU simulator.])
+
RTEMS_BSP_CLEANUP_OPTIONS(0, 1)
RTEMS_BSP_LINKCMDS