summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon3/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2014-05-21 09:37:16 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2014-10-06 14:44:44 +0200
commit5e92a40a38dc65958e56313f3a638cfe20c4b82b (patch)
treeb5a55d61117b8ecde07fd5b7dc78f1af1ac8e28e /c/src/lib/libbsp/sparc/leon3/Makefile.am
parentSPARC: Fatal_halt use source and exit codes (diff)
downloadrtems-5e92a40a38dc65958e56313f3a638cfe20c4b82b.tar.bz2
LEON3: use CPU_Fatal_halt for halt
By removing the bsp_reset() mechanism and instead relying on the CPU_Fatal_halt() routine SMP and single-core can halt by updating the _Internal_errors_What_happened structure and set the state to SYSTEM_STATE_TERMINATED (the generic way). This will be better for test scripts and debugger that can generically look into why the OS stopped. For SMP systems, only the fatal-reporting CPU waits until all other CPUs are powered down (with a time out of one clock tick). The reason why a fatal stop happend may be because CPU0 was soft-locked up so we can never trust that CPU0 should do the halt for us.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon3/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon3/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sparc/leon3/Makefile.am b/c/src/lib/libbsp/sparc/leon3/Makefile.am
index fa297acdc4..c5c9b77826 100644
--- a/c/src/lib/libbsp/sparc/leon3/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon3/Makefile.am
@@ -32,14 +32,14 @@ noinst_LIBRARIES += libbsp.a
libbsp_a_SOURCES =
# startup
-libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
+libbsp_a_SOURCES += startup/bspclean.c
+libbsp_a_SOURCES += ../../shared/bsplibc.c \
../../shared/bsppost.c ../../shared/bootcard.c startup/bspstart.c \
../../sparc/shared/bsppretaskinghook.c startup/bsppredriver.c \
../../sparc/shared/startup/bspgetworkarea.c ../../shared/sbrk.c \
startup/setvec.c \
startup/spurious.c startup/bspidle.S startup/bspdelay.c \
../../shared/bspinit.c ../../sparc/shared/startup/early_malloc.c
-libbsp_a_SOURCES += startup/bspreset.c
libbsp_a_SOURCES += startup/cpucounter.c
libbsp_a_SOURCES += ../../sparc/shared/startup/bsp_fatal_exit.c
libbsp_a_SOURCES += startup/bsp_fatal_halt.c