summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2017-05-09 16:00:56 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2017-05-14 12:32:00 +0200
commit84e4d10ca346e7c89314845420a650b6dab316b4 (patch)
tree383fdb88425c721999aec3d36f9385e8347dd391 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parentleon, grtm: SMP support by using spin-locks (diff)
downloadrtems-84e4d10ca346e7c89314845420a650b6dab316b4.tar.bz2
leon, apbuart: remove old RAW UART driver
This driver was initially intended for APBUART access on GRLIB PCI peripherals (AMBA-over-PCI). There are already many APBUART drivers for LEON. Instead of using this one the termios APBUART should work on AMBA-over-PCI systems with recent changes on LEON3, however that has not been tested yet.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 94e10cd7d8..349b44d06d 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -154,7 +154,6 @@ libbsp_a_SOURCES += ../../sparc/shared/spw/grspw_router.c
# UART (RAW)
include_bsp_HEADERS += ../../sparc/shared/include/apbuart.h
-libbsp_a_SOURCES += ../../sparc/shared/uart/apbuart.c
# I2CMST
include_bsp_HEADERS += ../../sparc/shared/include/i2cmst.h