summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-05 15:49:38 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2007-12-05 15:49:38 +0000
commit7e15770cda0aed534ae2f8c1e6cdd7ac3f33e3ce (patch)
tree9f87a6ae90dd63576eda641065b5e964ee34e65c /c/src/lib/libbsp/sparc/leon2/Makefile.am
parent2007-12-05 Daniel Hellstrom <daniel@gaisler.com> (diff)
downloadrtems-7e15770cda0aed534ae2f8c1e6cdd7ac3f33e3ce.tar.bz2
2007-12-05 Daniel Hellstrom <daniel@gaisler.com>
* Makefile.am, preinstall.am: i2c should be on branch as well as CVS head.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 8dc30b1740..5a4c196f7e 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -114,6 +114,12 @@ uart_rel_SOURCES = ../../sparc/shared/uart/apbuart.c ../../sparc/shared/uart/apb
uart_rel_CPPFLAGS = $(AM_CPPFLAGS)
uart_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
+# I2CMST
+include_HEADERS += ../../sparc/shared/include/i2cmst.h
+noinst_PROGRAMS += i2cmst.rel
+i2cmst_rel_SOURCES = ../../sparc/shared/i2c/i2cmst.c
+i2cmst_rel_CPPFLAGS = $(AM_CPPFLAGS)
+i2cmst_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
if HAS_NETWORKING
noinst_PROGRAMS += leon_smc91111.rel