summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2014-05-19 17:27:55 +0200
committerDaniel Hellstrom <daniel@gaisler.com>2014-10-06 09:34:24 +0200
commitce4a7ae9da4c0999ac3ff90603e8198f136171b5 (patch)
treec7ee8bd590f355f5728579d5cf6337664262f6f4 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parentSPARC BSPs: remove BSP_fatal_return unreached code (diff)
downloadrtems-ce4a7ae9da4c0999ac3ff90603e8198f136171b5.tar.bz2
SPARC: add BSP specific error handler
Instead of calling the system call TA instruction directly it is better paractise to isolate the trap implementation to the system call functions. BSP_fatal_exit() is added.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index e808b33723..3f8edf436b 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -60,6 +60,7 @@ libbsp_a_SOURCES += startup/bspidle.c
libbsp_a_SOURCES += ../../shared/bspinit.c
libbsp_a_SOURCES += startup/bspdelay.c
libbsp_a_SOURCES += ../../sparc/shared/startup/early_malloc.c
+libbsp_a_SOURCES += ../../sparc/shared/startup/bsp_fatal_exit.c
# ISR Handler
libbsp_a_SOURCES += ../../sparc/shared/cpu.c