summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2014-02-24 12:45:00 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2014-02-24 16:12:02 +0100
commita4bc90af4ee55e72b18de4b64da6338634490760 (patch)
tree64cd9a60f941054d469ce5061d9d77847de2e308 /c/src/lib/libbsp/sparc/leon2/Makefile.am
parentscore: Fix thread TLS area initialization (diff)
downloadrtems-a4bc90af4ee55e72b18de4b64da6338634490760.tar.bz2
sparc: Fix CPU counter support
The SPARC processors supported by RTEMS have no built-in CPU counter support. We have to use some hardware counter module for this purpose. The BSP must provide a 32-bit register which contains the current CPU counter value and a function for the difference calculation. It can use for example the GPTIMER instance used for the clock driver.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am1
1 files changed, 0 insertions, 1 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 8bbe69b201..c08f159f81 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -52,7 +52,6 @@ libbsp_a_SOURCES += ../../shared/bspclean.c ../../shared/bsplibc.c \
../../shared/sbrk.c startup/setvec.c startup/spurious.c startup/bspidle.c \
../../shared/bspinit.c startup/bspdelay.c \
../../sparc/shared/startup/early_malloc.c
-libbsp_a_SOURCES += ../../shared/cpucounterread.c
# ISR Handler
libbsp_a_SOURCES += ../../sparc/shared/irq_asm.S
# gnatsupp