summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon2/Makefile.am
diff options
context:
space:
mode:
authorDaniel Hellstrom <daniel@gaisler.com>2012-05-16 17:20:35 +0200
committerGedare Bloom <gedare@rtems.org>2012-05-16 13:29:13 -0400
commit226d48d8262ff040aeca439c22e7398179eb01cd (patch)
tree931d2a37d49440bd95902f9b367f72f02ea5db2c /c/src/lib/libbsp/sparc/leon2/Makefile.am
parentnfsclient: Fix symbolic link evaluation (diff)
downloadrtems-226d48d8262ff040aeca439c22e7398179eb01cd.tar.bz2
LEON: moved register definitions into grlib header file
Some register layout definitions for LEON3 reside in ambapp.h which does not really has anything to do with device registers. The register structures has been incorrectly named LEON3_*, the cores are not only used on LEON3 but on LEON4 and perhaps on LEON5 when that day comes. Some structures has been renamed according to the GRLIB core name instead, which CPU that actually use it is not relevant. Drivers has been updated with the new names. Signed-off-by: Daniel Hellstrom <daniel@gaisler.com>
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon2/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon2/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/leon2/Makefile.am b/c/src/lib/libbsp/sparc/leon2/Makefile.am
index 71e19f2c8c..9699bf1a32 100644
--- a/c/src/lib/libbsp/sparc/leon2/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon2/Makefile.am
@@ -78,6 +78,7 @@ libbsp_a_SOURCES += \
# AMBA bus
include_HEADERS += ../../sparc/shared/include/ambapp.h
include_HEADERS += ../../sparc/shared/include/ambapp_ids.h
+include_HEADERS += ../../sparc/shared/include/grlib.h
libbsp_a_SOURCES += ../../sparc/shared/amba/ambapp.c
libbsp_a_SOURCES += ../../sparc/shared/amba/ambapp_alloc.c
libbsp_a_SOURCES += ../../sparc/shared/amba/ambapp_count.c