summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 10:31:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 10:31:46 +0000
commit8cb3c27ef34fad5eadf21333776e29c80e2878d8 (patch)
tree5574f4d9d69e68145373b40bcc14bac8e27cde0e /c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am
parent2004-01-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8cb3c27ef34fad5eadf21333776e29c80e2878d8.tar.bz2
2004-01-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, leon_open_eth/Makefile.am, startup/Makefile.am, console/Makefile.am, gnatsupp/Makefile.am, timer/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * clock/Makefile.am, leon_open_eth/Makefile.am, startup/Makefile.am, console/Makefile.am, gnatsupp/Makefile.am, timer/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am26
1 files changed, 0 insertions, 26 deletions
diff --git a/c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am b/c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am
deleted file mode 100644
index 6c5cd1bd95..0000000000
--- a/c/src/lib/libbsp/sparc/leon/wrapup/Makefile.am
+++ /dev/null
@@ -1,26 +0,0 @@
-##
-## $Id$
-##
-
-# We only build the networking device driver if HAS_NETWORKING was defined
-if HAS_NETWORKING
-NETWORKING_DRIVER = leon_open_eth
-endif
-
-BSP_PIECES = startup console clock timer gnatsupp $(NETWORKING_DRIVER)
-
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../../../../libcpu/sparc/cache$(LIB_VARIANT).rel \
- ../../../../libcpu/sparc/reg_win$(LIB_VARIANT).rel \
- ../../../../libcpu/sparc/syscall$(LIB_VARIANT).rel
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-$(ARCH)/libbsp.a: $(OBJS)
- $(make-library)
-
-noinst_DATA = $(ARCH)/libbsp.a
-
-include $(top_srcdir)/../../../../automake/local.am