summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 05:42:03 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 05:42:03 +0000
commitbc71412e55bf7b00367b200b1118f0fffce56172 (patch)
tree5b6c846bbc582965dc017ee5c09f9bc230ee4927 /c/src/lib/libbsp/sparc/leon/startup/Makefile.am
parent2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-bc71412e55bf7b00367b200b1118f0fffce56172.tar.bz2
2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Misc cleanups and fixes. * start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/leon/startup/Makefile.am15
1 files changed, 6 insertions, 9 deletions
diff --git a/c/src/lib/libbsp/sparc/leon/startup/Makefile.am b/c/src/lib/libbsp/sparc/leon/startup/Makefile.am
index 09d9c8ac32..3c3e7f65a6 100644
--- a/c/src/lib/libbsp/sparc/leon/startup/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon/startup/Makefile.am
@@ -25,17 +25,14 @@ include $(top_srcdir)/../../../../automake/lib.am
$(PGM): $(OBJS)
$(make-rel)
-bsplib_DATA = linkcmds
+project_lib_DATA = linkcmds
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds
-
-all-local: $(OBJS) $(PGM) $(TMPINSTALL_FILES)
-
-.PRECIOUS: $(PGM)
+all-local: $(PGM) $(TMPINSTALL_FILES)
EXTRA_DIST = linkcmds setvec.c spurious.c boardinit.S
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
+
include $(top_srcdir)/../../../../automake/local.am