summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/leon/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-18 22:37:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-06-18 22:37:14 +0000
commit94a651251722b7cefc7feb94e04cfe8745225aae (patch)
tree636c2328a19f057d8ce9ce5cc11e7a7249a74e58 /c/src/lib/libbsp/sparc/leon/include/Makefile.am
parent2001-05-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-94a651251722b7cefc7feb94e04cfe8745225aae.tar.bz2
2001-05-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.in: Add bspopts.h. * include/.cvsignore: Add bspopts.h*, stamp-h*. * include/Makefile.am: Use *_HEADERS instead of *H_FILES. * include/bsp.h: Include bspopts.h.
Diffstat (limited to 'c/src/lib/libbsp/sparc/leon/include/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sparc/leon/include/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/sparc/leon/include/Makefile.am b/c/src/lib/libbsp/sparc/leon/include/Makefile.am
index 14deae14ea..e4f8750455 100644
--- a/c/src/lib/libbsp/sparc/leon/include/Makefile.am
+++ b/c/src/lib/libbsp/sparc/leon/include/Makefile.am
@@ -4,7 +4,7 @@
AUTOMAKE_OPTIONS = foreign 1.4
-H_FILES = bsp.h coverhd.h leon.h
+include_HEADERS = bsp.h coverhd.h leon.h bspopts.h
$(PROJECT_INCLUDE):
$(mkinstalldirs) $@
@@ -12,10 +12,8 @@ $(PROJECT_INCLUDE):
$(PROJECT_INCLUDE)/%.h: %.h
$(INSTALL_DATA) $< $@
-PREINSTALL_FILES += $(PROJECT_INCLUDE) $(H_FILES:%.h=$(PROJECT_INCLUDE)/%.h)
+PREINSTALL_FILES += $(PROJECT_INCLUDE) $(include_HEADERS:%=$(PROJECT_INCLUDE)/%)
all-local: $(PREINSTALL_FILES)
-EXTRA_DIST = bsp.h coverhd.h
-
include $(top_srcdir)/../../../../../../automake/local.am