summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
commit1072609587a7f1a877a8e059c7158045d19034f5 (patch)
tree1a2490dd280b4670d68dc4e2ab6658e449e7421d /c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
parentPatch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1072609587a7f1a877a8e059c7158045d19034f5.tar.bz2
Patch rtems-rc-20000104-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the sparc directory to automake. Ralf's note: The implementation of libbsp/sparc/* gives a nearly minimal example of the new configuration scheme.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/startup/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am b/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
new file mode 100644
index 0000000000..be6f29e3b9
--- /dev/null
+++ b/c/src/lib/libbsp/sparc/erc32/startup/Makefile.am
@@ -0,0 +1,41 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+VPATH = @srcdir@:@srcdir@/../../../shared
+
+PGM = ${ARCH}/startup.rel
+
+## C source names
+C_FILES = bspclean.c bsplibc.c bsppost.c bspstart.c main.c bootcard.c sbrk.c \
+ setvec.c spurious.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+# USE_INIT_FINI tells main.c what C++ help we need.
+
+AM_CPPFLAGS += -DUSE_INIT_FINI
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES = $(PROJECT_RELEASE)/lib/linkcmds
+
+all-local: ${ARCH} $(PGM) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = bspclean.c bspstart.c setvec.c spurious.c linkcmds
+
+include $(top_srcdir)/../../../../../../automake/local.am