summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-13 22:29:14 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-13 22:29:14 +0000
commit270042352bb97ab71be15205deded8fe44199b1e (patch)
tree9cfb92bb21d0f38bc102206a06a593c804614c9a /c/src/lib/libbsp/sparc/erc32/configure.in
parent2000-11-13 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-270042352bb97ab71be15205deded8fe44199b1e.tar.bz2
2000-11-13 Jiri Gaisler <jgais@ws.estec.esa.nl>
* Makefile.am, configure.in, gnatsupp/Makefile.am, gnatsupp/gnatsupp.c, include/Makefile.am, include/bsp.h, start/Makefile.am, startup/Makefile.am, startup/setvec.c, wrapup/Makefile.am: * erc32sonic: New directory. * erc32sonic/Makefile.am, erc32sonic/erc32sonic.c, erc32sonic/.cvsignore: New files. * include/erc32.h: New file. * startup/boardinit.S: New file. Big update of SPARC support for ERC32 and LEON. Added support for ERC32 without floating point. Added SONIC support as configured on Tharsys ERC32 board. The bsp's share various code in the shared directory: gnat-support, start-up code, etc. To decrease the foot-print, I removed the 16 kbyte start-up stack that was put in .bss and never reused once the system was up. The stack is now put between the heap and the workspace. To reclaim it, the user can do a rtems_region_extend to merge the stack to the heap region once the system is up.
Diffstat (limited to 'c/src/lib/libbsp/sparc/erc32/configure.in')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/configure.in b/c/src/lib/libbsp/sparc/erc32/configure.in
index 89a5e0693c..8ab22d7736 100644
--- a/c/src/lib/libbsp/sparc/erc32/configure.in
+++ b/c/src/lib/libbsp/sparc/erc32/configure.in
@@ -17,8 +17,11 @@ RTEMS_CANONICALIZE_TOOLS
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_CHECK_NETWORKING
RTEMS_CANONICAL_HOST
+AM_CONDITIONAL(HAS_NETWORKING,test "$HAS_NETWORKING" = "yes")
+
RTEMS_CONFIG_BUILD_SUBDIRS(tools)
RTEMS_PROJECT_ROOT
@@ -28,6 +31,7 @@ AC_OUTPUT(
Makefile
clock/Makefile
console/Makefile
+erc32sonic/Makefile
gnatsupp/Makefile
include/Makefile
start/Makefile