summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sparc/erc32/clock/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:59:35 +0000
commit1072609587a7f1a877a8e059c7158045d19034f5 (patch)
tree1a2490dd280b4670d68dc4e2ab6658e449e7421d /c/src/lib/libbsp/sparc/erc32/clock/Makefile.am
parentPatch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-1072609587a7f1a877a8e059c7158045d19034f5.tar.bz2
Patch rtems-rc-20000104-3.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts the sparc directory to automake. Ralf's note: The implementation of libbsp/sparc/* gives a nearly minimal example of the new configuration scheme.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sparc/erc32/clock/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sparc/erc32/clock/Makefile.am b/c/src/lib/libbsp/sparc/erc32/clock/Makefile.am
new file mode 100644
index 0000000000..542d572b47
--- /dev/null
+++ b/c/src/lib/libbsp/sparc/erc32/clock/Makefile.am
@@ -0,0 +1,29 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = ${ARCH}/clock.rel
+
+## C source names
+C_FILES = ckinit.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+include $(top_srcdir)/../../../../../../automake/local.am