summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/shmdr/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-03 15:27:06 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-03 15:27:06 +0000
commit57d673c9823621a66ca2bac86e1af367d233dc82 (patch)
treee293d6e407da900f6bc2b7ad600605d04a0c31b7 /c/src/lib/libbsp/shmdr/Makefile.am
parent2003-12-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-57d673c9823621a66ca2bac86e1af367d233dc82.tar.bz2
2003-12-03 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in shared/Makefile.am, shmdr/Makefile.am. * shared/Makefile.am: Remove. * shmdir/Makefile.am: Remove. * bsp.am: Add preinstallation dirstamp support.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/shmdr/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/c/src/lib/libbsp/shmdr/Makefile.am b/c/src/lib/libbsp/shmdr/Makefile.am
deleted file mode 100644
index 400a14ff3a..0000000000
--- a/c/src/lib/libbsp/shmdr/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-##
-## $Id$
-##
-
-
-PGM = $(ARCH)/shmdr.rel
-
-C_FILES = addlq.c cnvpkt.c getlq.c dump.c fatal.c getpkt.c init.c initlq.c \
- intr.c mpisr.c poll.c receive.c retpkt.c send.c setckvec.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/automake/compile.am
-include $(top_srcdir)/automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-$(PROJECT_RELEASE)/lib/shmdr$(LIB_VARIANT).rel: $(ARCH)/shmdr.rel
- $(INSTALL_DATA) $< $@
-
-# the .rel file built here will be put into libbsp.a by
-# ../$(RTEMS_BSP_FAMILY)/wrapup/Makefile
-
-$(PROJECT_INCLUDE):
- $(mkinstalldirs) $@
-
-if HAS_MP
-include_HEADERS = shm_driver.h mpci.h
-endif
-
-$(PROJECT_INCLUDE)/%.h: %.h
- $(INSTALL_DATA) $< $@
-
-PREINSTALL_FILES = $(PROJECT_INCLUDE)
-PREINSTALL_FILES += $(include_HEADERS:%.h=$(PROJECT_INCLUDE)/%.h)
-
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/shmdr$(LIB_VARIANT).rel
-
-if HAS_MP
-all-local: $(PREINSTALL_FILES) $(PGM) $(TMPINSTALL_FILES)
-endif
-
-.PRECIOUS: $(PGM)
-
-EXTRA_DIST = README addlq.c cnvpkt.c dump.c fatal.c getlq.c getpkt.c init.c \
- initlq.c intr.c mpisr.c poll.c receive.c retpkt.c send.c \
- setckvec.c
-
-include $(top_srcdir)/automake/local.am