summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 21:04:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 21:04:35 +0000
commitcd67dcaf009326c46d67951976f87a6559ed7928 (patch)
tree96f9988bfe3f4c56ea79b00f2146f8c09c6be5d0 /c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-cd67dcaf009326c46d67951976f87a6559ed7928.tar.bz2
2001-10-11 Alexandra Kossovsky <sasha@oktet.ru>
* clock/Makefile.am, clock/ckinit.c, clock/.cvsignore, Makefile.am, README, bsp_specs, console/Makefile.am, console/console.c, console/.cvsignore, include/Makefile.am, include/bsp.h, include/coverhd.h, include/syscall.h, include/ramdisk.h, include/.cvsignore, start/Makefile.am, start/start.S, start/.cvsignore, startup/Makefile.am, startup/bspstart.c, startup/hw_init.c, startup/linkcmds, startup/linkcmds-le, startup/linkcmds-le.coff, startup/.cvsignore, timer/Makefile.am, timer/timer.c, timer/.cvsignore, wrapup/Makefile.am, wrapup/.cvsignore, configure.ac, .cvsignore, ChangeLog: New files. Reviewed and updated to latest automake and autoconf standards by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am b/c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am
new file mode 100644
index 0000000000..b30445beb9
--- /dev/null
+++ b/c/src/lib/libbsp/sh/simsh4/wrapup/Makefile.am
@@ -0,0 +1,40 @@
+##
+## $Id$
+##
+## build and install libbsp
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+BSP_PIECES = startup console clock ramdisk timer
+
+# pieces to pick up out of libcpu/sh
+CPU_PIECES = score
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/$(piece).rel) \
+ $(foreach piece, $(CPU_PIECES), ../../../../libcpu/$(RTEMS_CPU)/simsh4/$(piece)/$(ARCH)/$(piece).rel)
+
+LIB = $(ARCH)/libbsp.a
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): $(OBJS)
+ $(make-library)
+
+$(PROJECT_RELEASE)/lib/libbsp$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/libbsp$(LIB_VARIANT).a
+
+all-local: $(ARCH) $(OBJS) $(LIB) $(TMPINSTALL_FILES)
+
+.PRECIOUS: $(LIB)
+
+include $(top_srcdir)/../../../../../../automake/local.am