summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 21:04:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-10-11 21:04:35 +0000
commitcd67dcaf009326c46d67951976f87a6559ed7928 (patch)
tree96f9988bfe3f4c56ea79b00f2146f8c09c6be5d0 /c/src/lib/libbsp/sh/simsh4/configure.ac
parent2001-10-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-cd67dcaf009326c46d67951976f87a6559ed7928.tar.bz2
2001-10-11 Alexandra Kossovsky <sasha@oktet.ru>
* clock/Makefile.am, clock/ckinit.c, clock/.cvsignore, Makefile.am, README, bsp_specs, console/Makefile.am, console/console.c, console/.cvsignore, include/Makefile.am, include/bsp.h, include/coverhd.h, include/syscall.h, include/ramdisk.h, include/.cvsignore, start/Makefile.am, start/start.S, start/.cvsignore, startup/Makefile.am, startup/bspstart.c, startup/hw_init.c, startup/linkcmds, startup/linkcmds-le, startup/linkcmds-le.coff, startup/.cvsignore, timer/Makefile.am, timer/timer.c, timer/.cvsignore, wrapup/Makefile.am, wrapup/.cvsignore, configure.ac, .cvsignore, ChangeLog: New files. Reviewed and updated to latest automake and autoconf standards by Ralf Corsepius <corsepiu@faw.uni-ulm.de>.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/configure.ac b/c/src/lib/libbsp/sh/simsh4/configure.ac
new file mode 100644
index 0000000000..5b473fa079
--- /dev/null
+++ b/c/src/lib/libbsp/sh/simsh4/configure.ac
@@ -0,0 +1,35 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.52)
+AC_INIT
+AC_CONFIG_SRCDIR([bsp_specs])
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-sh-simsh4,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
+RTEMS_CANONICALIZE_TOOLS
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+# Explicitly list all Makefiles here
+AC_CONFIG_FILES([Makefile
+console/Makefile
+include/Makefile
+start/Makefile
+startup/Makefile
+clock/Makefile
+timer/Makefile
+wrapup/Makefile
+])
+AC_OUTPUT