summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 10:19:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2008-09-29 10:19:37 +0000
commit64eb0c7f4269504e45e73cee0aa4320f9e5ecedf (patch)
tree8ed7d77d393ed0c06b4e9e71b9f71bc40d30edf6 /c/src/lib/libbsp/sh/simsh4/Makefile.am
parent2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-64eb0c7f4269504e45e73cee0aa4320f9e5ecedf.tar.bz2
2008-09-29 Ralf Corsépius <ralf.corsepius@rtems.org>
* Makefile.am: Eliminate *_SOURCES.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index b1ceba252c..4e38040ecb 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -36,19 +36,21 @@ dist_project_lib_DATA += startup/linkcmds startup/linkcmds-le \
startup/linkcmds-le.coff
noinst_LIBRARIES = libbsp.a
+libbsp_a_SOURCES =
-startup_SOURCES = startup/hw_init.c ../../shared/bsplibc.c \
+# startup
+libbsp_a_SOURCES += startup/hw_init.c ../../shared/bsplibc.c \
../../shared/bsppost.c ../../shared/bsppredriverhook.c \
../../shared/bsppretaskinghook.c ../../shared/bspgetworkarea.c \
../shared/bspstart.c ../../shared/bspclean.c ../../shared/sbrk.c \
../../shared/bootcard.c ../../shared/gnatinstallhandler.c \
../shared/bsphwinit.c
-clock_SOURCES = clock/ckinit.c
-console_SOURCES = console/console.c ../../shared/dummy_printk_support.c
-timer_SOURCES = timer/timer.c
-
-libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
- $(timer_SOURCES)
+# clock
+libbsp_a_SOURCES += clock/ckinit.c
+# console
+libbsp_a_SOURCES += console/console.c ../../shared/dummy_printk_support.c
+# timer
+libbsp_a_SOURCES += timer/timer.c
libbsp_a_LIBADD = \
../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/score.rel