summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/simsh4/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:36 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:36 +0000
commit628d804f36cd252ed24611b0ef9bc0c643cfc5a1 (patch)
treebe5af4f5bbfd76ce4ba3f3858407576c085f17a0 /c/src/lib/libbsp/sh/simsh4/Makefile.am
parent2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-628d804f36cd252ed24611b0ef9bc0c643cfc5a1.tar.bz2
2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bsp.h, startup/hw_init.c, startup/linkcmds, startup/linkcmds-le, startup/linkcmds-le.coff: Use shared bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. After factoring this out, it turned out that all SuperH BSPs has the same bsp_start() implementation so this was made shared. * startup/bspstart.c: Removed.
Diffstat (limited to 'c/src/lib/libbsp/sh/simsh4/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/simsh4/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sh/simsh4/Makefile.am b/c/src/lib/libbsp/sh/simsh4/Makefile.am
index a31cb6b0e3..3ec83b3895 100644
--- a/c/src/lib/libbsp/sh/simsh4/Makefile.am
+++ b/c/src/lib/libbsp/sh/simsh4/Makefile.am
@@ -35,8 +35,10 @@ dist_project_lib_DATA += startup/linkcmds startup/linkcmds-le \
startup_SOURCES = startup/hw_init.c ../../shared/bsplibc.c \
../../shared/bsppost.c ../../shared/bsppredriverhook.c \
- startup/bspstart.c ../../shared/bspclean.c ../../shared/sbrk.c \
- ../../shared/bootcard.c ../../shared/gnatinstallhandler.c
+ ../../shared/bsppretaskinghook.c ../shared/bspgetworkarea.c \
+ ../shared/bspstart.c ../../shared/bspclean.c ../../shared/sbrk.c \
+ ../../shared/bootcard.c ../../shared/gnatinstallhandler.c \
+ ../shared/bsphwinit.c
clock_SOURCES = clock/ckinit.c
console_SOURCES = console/console.c ../../shared/dummy_printk_support.c
timer_SOURCES = timer/timer.c