summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-27 16:00:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-11-27 16:00:50 +0000
commit86ec6edbe9851ff7e2dd0bd5412d30461cfb2f59 (patch)
tree3adc2c2fc1830441d1bcf3288754265e1e9fbe85 /c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
parent2000-11-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-86ec6edbe9851ff7e2dd0bd5412d30461cfb2f59.tar.bz2
2000-11-27 Joel Sherrill <joel@OARcorp.com>
* The shsim is for the SH simulator in gdb. It should be able to be used with multiple SH CPU models. * .cvsignore, ChangeLog, Makefile.am, README, bsp_specs, configure.in, clock/.cvsignore, clock/Makefile.am, clock/clockdrv.c, console/.cvsignore, console/Makefile.am, console/console-io.c, console/console-support.S, include/.cvsignore, include/Makefile.am, include/bsp.h, start/.cvsignore, start/Makefile.am, start/regs.S, start/start.S, startup/.cvsignore, startup/Makefile.am, startup/bspstart.c, startup/linkcmds, wrapup/.cvsignore, wrapup/Makefile.am: New files.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am b/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
new file mode 100644
index 0000000000..7a5744c97d
--- /dev/null
+++ b/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+BSP_FILES = startup clock console timer
+
+# CPU_PIECES = score
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/compile.am
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+# bummer; have to use $foreach since % pattern subst rules only replace 1x
+OBJS = $(foreach piece, $(BSP_FILES), $(wildcard ../$(piece)/$(ARCH)/*.o)) \
+ $(wildcard ../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/*.o) \
+ $(foreach piece, $(GENERIC_FILES), ../../../$(piece)/$(ARCH)/$(piece).rel)
+
+LIB = $(ARCH)/libbsp.a
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(LIB): ${OBJS}
+ $(make-library)
+
+$(PROJECT_RELEASE)/lib/libbsp$(LIB_VARIANT).a: $(LIB)
+ $(INSTALL_DATA) $< $@
+
+TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/libbsp$(LIB_VARIANT).a
+
+all-local: ${ARCH} $(TMPINSTALL_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am