summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:21 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:21 +0000
commit4c89e236a37df23c3fb23fd375f99a285e514ce3 (patch)
tree57b1fd81f735f018dcef89329b95ad55a3eb0742 /c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
parent2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-4c89e236a37df23c3fb23fd375f99a285e514ce3.tar.bz2
2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes. * wrapup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am b/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
index 6a161a4ab6..01d4dd6483 100644
--- a/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/wrapup/Makefile.am
@@ -2,7 +2,7 @@
## $Id$
##
-BSP_FILES = startup clock console timer gdbsci scitab
+BSP_FILES = startup clock console gdbsci scitab
CPU_PIECES = score
@@ -10,8 +10,8 @@ include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am
# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_FILES), $(wildcard \
- ../$(piece)/$(ARCH)/*.$(OBJEXT))) $(foreach piece, $(CPU_PIECES), \
+OBJS = $(foreach piece, $(BSP_FILES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
+ $(foreach piece, $(CPU_PIECES), \
../../../../libcpu/$(RTEMS_CPU)/$(RTEMS_CPU_MODEL)/$(ARCH)/$(piece).rel)
LIB = $(ARCH)/libbsp.a