summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-24 16:39:44 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-24 16:39:44 +0000
commitae1a501c95543752facf37234e8108aa41280357 (patch)
treeb7dc926e7cb11384e050e9b7e433ea630e2d1fba /c/src/lib/libbsp/sh/shsim/Makefile.am
parent2008-09-24 Joel Sherrill <joel.sherrill@OARcorp.com> (diff)
downloadrtems-ae1a501c95543752facf37234e8108aa41280357.tar.bz2
2008-09-24 Joel Sherrill <joel.sherrill@OARcorp.com>
* Makefile.am, configure.ac, clock/clockdrv.c, include/bsp.h, start/start.S, startup/linkcmds: Now runs ticker and hello on sh-rtems4.10-gdb. The SH simulator in gdb has no hardware IO or interrupt simulation so we use the trap interface to print. * gdbsci/gdbsci.c: Removed.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/shsim/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/Makefile.am b/c/src/lib/libbsp/sh/shsim/Makefile.am
index 3f0cfabd65..2afc7168ad 100644
--- a/c/src/lib/libbsp/sh/shsim/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/Makefile.am
@@ -40,17 +40,14 @@ startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
../../shared/bspclean.c ../../shared/sbrk.c ../../shared/bootcard.c \
../../shared/gnatinstallhandler.c ../shared/bsphwinit.c
clock_SOURCES = clock/clockdrv.c
-scitab_SOURCES = scitab.c
-gdbsci_SOURCES = gdbsci/gdbsci.c
-# FIXME: trap34 is unused
trap34_SOURCES = trap34/console-io.c trap34/console-support.S \
../../shared/dummy_printk_support.c
-console_SOURCES = ../../sh/shared/console.c
+console_SOURCES = ../../shared/console-polled.c
noinst_LIBRARIES = libbsp.a
libbsp_a_SOURCES = $(startup_SOURCES) $(clock_SOURCES) $(console_SOURCES) \
- $(gdbsci_SOURCES) $(scitab_SOURCES) $(trap34_SOURCES)
+ $(scitab_SOURCES) $(trap34_SOURCES)
libbsp_a_LIBADD = \
../../../libcpu/@RTEMS_CPU@/@RTEMS_CPU_MODEL@/score.rel