summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/shsim/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:31 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:31 +0000
commit512d0fcba10b84737fbaca5dd078995000667120 (patch)
tree672cf547719761f6016854ba3cdf72d541c18d62 /c/src/lib/libbsp/sh/shsim/Makefile.am
parent2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-512d0fcba10b84737fbaca5dd078995000667120.tar.bz2
2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bsp.h, startup/linkcmds: Use shared bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. After factoring this out, it turned out that all SuperH BSPs has the same bsp_start() implementation so this was made shared.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/shsim/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sh/shsim/Makefile.am b/c/src/lib/libbsp/sh/shsim/Makefile.am
index d57ce314b9..7b8312090b 100644
--- a/c/src/lib/libbsp/sh/shsim/Makefile.am
+++ b/c/src/lib/libbsp/sh/shsim/Makefile.am
@@ -35,9 +35,10 @@ BUILT_SOURCES = scitab.c
CLEANFILES = scitab.c
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
- ../../shared/bsppredriverhook.c startup/bspstart.c \
+ ../../shared/bsppredriverhook.c ../shared/bspstart.c \
+ ../../shared/bsppretaskinghook.c ../shared/bspgetworkarea.c \
../../shared/bspclean.c ../../shared/sbrk.c ../../shared/bootcard.c \
- ../../shared/gnatinstallhandler.c
+ ../../shared/gnatinstallhandler.c ../shared/bsphwinit.c
clock_SOURCES = clock/clockdrv.c
scitab_SOURCES = scitab.c
gdbsci_SOURCES = gdbsci/gdbsci.c