summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-12-11 04:09:16 +0000
commit968b78dbc686c75d9a796bfde0f61f8f16d7b2aa (patch)
tree07fcf5c17bb0b1ab412e81ed13dac2779736c0e7 /c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
parent2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-968b78dbc686c75d9a796bfde0f61f8f16d7b2aa.tar.bz2
2003-12-11 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* start/Makefile.am: Misc cleanups and fixes. * startup/Makefile.am: Misc cleanups and fixes.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/startup/Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am b/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
index 4392685d00..ef4f22ac7c 100644
--- a/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
@@ -20,28 +20,25 @@ include $(top_srcdir)/../../../../automake/lib.am
# (OPTIONAL) Add local stuff here using +=
#
-bsplib_DATA = linkcmds linkcmds.rom linkcmds.rom2ram
-
-$(PROJECT_RELEASE)/lib/linkcmds: linkcmds
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_RELEASE)/lib/linkcmds.rom: linkcmds.rom
- $(INSTALL_DATA) $< $@
-
-$(PROJECT_RELEASE)/lib/linkcmds.rom2ram: linkcmds.rom2ram
- $(INSTALL_DATA) $< $@
+project_lib_DATA = linkcmds linkcmds.rom linkcmds.rom2ram
$(PGM): $(OBJS)
$(make-rel)
-TMPINSTALL_FILES += $(PROJECT_RELEASE)/lib/linkcmds \
- $(PROJECT_RELEASE)/lib/linkcmds.rom \
- $(PROJECT_RELEASE)/lib/linkcmds.rom2ram
+all-local: $(TMPINSTALL_FILES) $(PGM)
-all-local: $(TMPINSTALL_FILES) $(OBJS) $(PGM)
+EXTRA_DIST = bspclean.c bspstart.c linkcmds linkcmds.rom linkcmds.rom2ram
-.PRECIOUS: $(PGM)
+${PROJECT_RELEASE}/lib/linkcmds: linkcmds ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds
-EXTRA_DIST = bspclean.c bspstart.c linkcmds linkcmds.rom linkcmds.rom2ram
+${PROJECT_RELEASE}/lib/linkcmds.rom: linkcmds.rom ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds.rom
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds.rom
+
+${PROJECT_RELEASE}/lib/linkcmds.rom2ram: linkcmds.rom2ram ${PROJECT_RELEASE}/lib/$(dirstamp)
+ $(INSTALL_DATA) $< ${PROJECT_RELEASE}/lib/linkcmds.rom2ram
+TMPINSTALL_FILES += ${PROJECT_RELEASE}/lib/linkcmds.rom2ram
include $(top_srcdir)/../../../../automake/local.am