summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 09:59:30 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 09:59:30 +0000
commit38e4124f67085a3711cc91651d128b7fc05595ca (patch)
treef74c6d23147b3645578a7c4b667afe2540c0b84f /c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
parentRemove unnecessary .cvsignore. (diff)
downloadrtems-38e4124f67085a3711cc91651d128b7fc05595ca.tar.bz2
2004-01-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in console/Makefile.am, hw_init/Makefile.am, startup/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * console/Makefile.am, hw_init/Makefile.am, startup/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh4/startup/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am b/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
deleted file mode 100644
index 11f86d4def..0000000000
--- a/c/src/lib/libbsp/sh/gensh4/startup/Makefile.am
+++ /dev/null
@@ -1,53 +0,0 @@
-##
-## $Id$
-##
-
-VPATH = @srcdir@:@srcdir@/../../shared:@srcdir@/../../../shared
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = bsplibc.c bsppost.c bspstart.c bspclean.c sbrk.c bootcard.c main.c \
- gnatinstallhandler.c
-
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-project_lib_DATA = linkcmds linkcmds.rom linkcmds.rom2ram
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-all-local: $(TMPINSTALL_FILES) $(PGM)
-
-EXTRA_DIST = bspstart.c linkcmds linkcmds.rom linkcmds.rom2ram
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-$(PROJECT_LIB)/linkcmds.rom: linkcmds.rom $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds.rom
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds.rom
-
-$(PROJECT_LIB)/linkcmds.rom2ram: linkcmds.rom2ram $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds.rom2ram
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds.rom2ram
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am