summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
commit94608578a2c5d90d87ca729bb5d45f945679254a (patch)
tree140f91ec5f522c2c11a18350b6868535a7a97e67 /c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
parentPatch from Eric Valette <valette@crf.canon.fr> that makes sure the (diff)
downloadrtems-94608578a2c5d90d87ca729bb5d45f945679254a.tar.bz2
Patch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts nearly all of libbsp/sh to automake. Comments follow: 1. Almost full automake support for the libbsp/sh/ subdirectories (exception libbsp/sh/gensh*/wrapup/*) 2. Fixes for libbsp/bare/* 3. Updates to libbsp/* configuration which supports old (autoconf/deep configuration) and new (automake/flat/cascaded configuration) style configuration of libbsp/<cpu>/*
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am b/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
new file mode 100644
index 0000000000..729473ac56
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
@@ -0,0 +1,36 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+
+PGM = $(ARCH)/scitab.rel
+
+## C source names
+C_FILES = scitab.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+OBJS = $(C_O_FILES)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../../../automake/lib.am
+
+SHGEN = $(PROJECT_ROOT)/tools/cpu/sh/shgen
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+$(PGM): ${OBJS}
+ $(make-rel)
+
+all-local: ${ARCH} $(PGM)
+
+scitab.c: $(SHGEN)
+ $(SHGEN) -H $(HZ) sci > $@
+
+# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
+
+EXTRA_DIST = $(C_FILES)
+
+include $(top_srcdir)/../../../../../../automake/local.am