summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 02:38:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-29 02:38:37 +0000
commit0f14e454d02840bb640fda3d5a034d270b1539b9 (patch)
treeb0c3c849c9ac8d0d094ca1ed9e746b655a678b7a /c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
parentRemove unnecessary .cvsignore (diff)
downloadrtems-0f14e454d02840bb640fda3d5a034d270b1539b9.tar.bz2
2004-01-28 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in console/Makefile.am, scitab/Makefile.am, startup/Makefile.am, wrapup/Makefile.am. Use automake compilation rules. * console/Makefile.am, scitab/Makefile.am, startup/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am b/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
deleted file mode 100644
index af1ebd3aa9..0000000000
--- a/c/src/lib/libbsp/sh/gensh2/scitab/Makefile.am
+++ /dev/null
@@ -1,31 +0,0 @@
-##
-## $Id$
-##
-
-PGM = $(ARCH)/scitab.rel
-
-C_FILES = scitab.c
-OBJS = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-SHGEN = $(PROJECT_TOPdir)/tools/cpu/sh/shgen
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-scitab.c: $(SHGEN)
- $(SHGEN) -H @CPU_CLOCK_RATE_HZ@ sci > $@
-
-# the .rel file built here will be put into libbsp.a by ../wrapup/Makefile
-
-all-local: $(OBJS) $(PGM)
-
-.PRECIOUS: $(PGM)
-
-include $(top_srcdir)/../../../../automake/local.am