summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh2/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-01-10 13:56:35 +0000
commit94608578a2c5d90d87ca729bb5d45f945679254a (patch)
tree140f91ec5f522c2c11a18350b6868535a7a97e67 /c/src/lib/libbsp/sh/gensh2/configure.in
parentPatch from Eric Valette <valette@crf.canon.fr> that makes sure the (diff)
downloadrtems-94608578a2c5d90d87ca729bb5d45f945679254a.tar.bz2
Patch rtems-rc-20000104-2.diff from Ralf Corsepius <corsepiu@faw.uni-ulm.de>
that converts nearly all of libbsp/sh to automake. Comments follow: 1. Almost full automake support for the libbsp/sh/ subdirectories (exception libbsp/sh/gensh*/wrapup/*) 2. Fixes for libbsp/bare/* 3. Updates to libbsp/* configuration which supports old (autoconf/deep configuration) and new (automake/flat/cascaded configuration) style configuration of libbsp/<cpu>/*
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh2/configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/c/src/lib/libbsp/sh/gensh2/configure.in b/c/src/lib/libbsp/sh/gensh2/configure.in
new file mode 100644
index 0000000000..95ba513044
--- /dev/null
+++ b/c/src/lib/libbsp/sh/gensh2/configure.in
@@ -0,0 +1,31 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl $Id$
+
+AC_PREREQ(2.13)
+AC_INIT(bsp_specs)
+RTEMS_TOP(../../../../../..)
+AC_CONFIG_AUX_DIR(../../../../../..)
+
+RTEMS_CANONICAL_TARGET_CPU
+AM_INIT_AUTOMAKE(rtems-c-src-lib-libbsp-sh-gensh1,$RTEMS_VERSION,no)
+AM_MAINTAINER_MODE
+
+RTEMS_ENABLE_LIBCDIR
+
+RTEMS_ENV_RTEMSBSP
+RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_BSP_CACHE(RTEMS_BSP)
+RTEMS_CANONICAL_HOST
+
+RTEMS_PROJECT_ROOT
+
+# Explicitly list a Makefile here
+AC_OUTPUT(
+Makefile
+console/Makefile
+include/Makefile
+scitab/Makefile
+start/Makefile
+startup/Makefile
+wrapup/Makefile)