summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 01:13:34 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 01:13:34 +0000
commitae5544753a9bf2ed396d928c9c0456bf35526f2a (patch)
tree01a987907e8fd51acc818d1ae20181a7d1b3a0db /c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
parentReformat/Cleanups. (diff)
downloadrtems-ae5544753a9bf2ed396d928c9c0456bf35526f2a.tar.bz2
2004-01-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in console/Makefile.am, scitab/Makefile.am, startup/Makefile.am, wrapup/Makefile.am. Use automake-compilation rules. * console/Makefile.am, scitab/Makefile.am, startup/Makefile.am, wrapup/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/startup/Makefile.am44
1 files changed, 0 insertions, 44 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am b/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
deleted file mode 100644
index 0d91a91506..0000000000
--- a/c/src/lib/libbsp/sh/gensh1/startup/Makefile.am
+++ /dev/null
@@ -1,44 +0,0 @@
-##
-## $Id$
-##
-
-VPATH = @srcdir@:@srcdir@/../../shared:@srcdir@/../../../shared
-
-PGM = $(ARCH)/startup.rel
-
-C_FILES = bsplibc.c bsppost.c bspstart.c bspclean.c sbrk.c bootcard.c main.c \
- gnatinstallhandler.c
-C_O_FILES = $(C_FILES:%.c=$(ARCH)/%.$(OBJEXT))
-
-OBJS = $(C_O_FILES)
-
-include $(top_srcdir)/../../../../automake/compile.am
-include $(top_srcdir)/../../../../automake/lib.am
-
-#
-# (OPTIONAL) Add local stuff here using +=
-#
-
-$(PGM): $(OBJS)
- $(make-rel)
-
-project_lib_DATA = linkcmds
-
-all-local: $(PGM) $(TMPINSTALL_FILES)
-
-EXTRA_DIST = bspclean.c bspstart.c linkcmds
-
-TMPINSTALL_FILES =
-
-$(PROJECT_LIB)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_LIB)
- @: > $(PROJECT_LIB)/$(dirstamp)
-TMPINSTALL_FILES += $(PROJECT_LIB)/$(dirstamp)
-
-$(PROJECT_LIB)/linkcmds: linkcmds $(PROJECT_LIB)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_LIB)/linkcmds
-TMPINSTALL_FILES += $(PROJECT_LIB)/linkcmds
-
-CLEANFILES = $(TMPINSTALL_FILES)
-
-include $(top_srcdir)/../../../../automake/local.am