summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:43:22 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-29 14:43:22 +0000
commitd0d6a5c5b6dc2411b53b7077771ae29b5d6e2818 (patch)
tree55db08f706a59adcd3aa80616db9695ae692162b /c/src/lib/libbsp/sh/gensh1/Makefile.am
parent2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-d0d6a5c5b6dc2411b53b7077771ae29b5d6e2818.tar.bz2
2003-09-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. Reflect changes to bsp.am. * include/Makefile.am: Remove. * configure.ac: Reflect changes above.
Diffstat (limited to 'c/src/lib/libbsp/sh/gensh1/Makefile.am')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/Makefile.am b/c/src/lib/libbsp/sh/gensh1/Makefile.am
index 0e174428bb..0d7bbc2ef9 100644
--- a/c/src/lib/libbsp/sh/gensh1/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh1/Makefile.am
@@ -5,12 +5,20 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
# wrapup is the one that actually builds and installs the library
-# from the individual .rel files built in other directories
-SUBDIRS = include start startup scitab console wrapup
+# from the individual .rel files built in other directories
+SUBDIRS = . start startup scitab console wrapup
include $(top_srcdir)/../../bsp.am
-EXTRA_DIST = bsp_specs times
+include_HEADERS += include/coverhd.h
+
+all-local: $(PREINSTALL_FILES)
+
+EXTRA_DIST = times
+
+$(PROJECT_INCLUDE)/coverhd.h: include/coverhd.h
+ $(INSTALL_DATA) $< $@
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/coverhd.h
include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am