summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/sh/gensh1/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2008-09-15 19:18:29 +0000
commit11a6c974621241c2d556112fe62700b7dd355b5b (patch)
tree9a794ce5e1eae9bb0fd93e995922057b6748f8a5 /c/src/lib/libbsp/sh/gensh1/Makefile.am
parent2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com> (diff)
downloadrtems-11a6c974621241c2d556112fe62700b7dd355b5b.tar.bz2
2008-09-15 Joel Sherrill <joel.sherrill@oarcorp.com>
* Makefile.am, configure.ac, include/bsp.h, startup/linkcmds: Use shared bsp_get_work_area() in its own file and rely on BSP Framework to perform more initialization. After factoring this out, it turned out that all SuperH BSPs has the same bsp_start() implementation so this was made shared. * startup/bspstart.c: Removed.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/sh/gensh1/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/c/src/lib/libbsp/sh/gensh1/Makefile.am b/c/src/lib/libbsp/sh/gensh1/Makefile.am
index b9916f5cc4..81f6c0c732 100644
--- a/c/src/lib/libbsp/sh/gensh1/Makefile.am
+++ b/c/src/lib/libbsp/sh/gensh1/Makefile.am
@@ -35,8 +35,9 @@ BUILT_SOURCES = scitab.c
CLEANFILES = scitab.c
startup_SOURCES = ../../shared/bsplibc.c ../../shared/bsppost.c \
- ../../shared/bsppredriverhook.c startup/bspstart.c startup/bspclean.c \
- ../../shared/sbrk.c ../../shared/bootcard.c \
+ ../../shared/bsppredriverhook.c ../shared/bspstart.c startup/bspclean.c \
+ ../shared/bspgetworkarea.c ../../shared/bsppretaskinghook.c \
+ ../../shared/sbrk.c ../../shared/bootcard.c ../shared/bsphwinit.c \
../../shared/gnatinstallhandler.c
scitab_SOURCES = scitab.c
console_SOURCES = ../../sh/shared/console.c