summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/virtex4/Makefile.am
diff options
context:
space:
mode:
authorRic Claus <claus@slac.stanford.edu>2012-11-30 15:56:04 -0800
committerSebastian Huber <sebastian.huber@embedded-brains.de>2012-12-01 09:04:14 +0100
commit5b822ab26adf42d7ecf332adc2f89651d934ce1d (patch)
tree6a62cd722d64e8c44a3fe41ded2a30e4c845a2a8 /c/src/lib/libbsp/powerpc/virtex4/Makefile.am
parentSupport additional shell keystrokes. (diff)
downloadrtems-5b822ab26adf42d7ecf332adc2f89651d934ce1d.tar.bz2
Virtex4 BSP: Various updates and improvements.
Switched to using the PPC403 clock driver. Added support for the MMU but didn't enable it by default. Made some functions static to avoid compiler warnings. Added a README.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/virtex4/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/c/src/lib/libbsp/powerpc/virtex4/Makefile.am b/c/src/lib/libbsp/powerpc/virtex4/Makefile.am
index adce2972f5..58fcea5beb 100644
--- a/c/src/lib/libbsp/powerpc/virtex4/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/virtex4/Makefile.am
@@ -36,15 +36,12 @@ libbsp_a_SOURCES = startup/bspclean.c \
startup/bspstart.c \
../../shared/bootcard.c \
../../shared/sbrk.c \
- ../../shared/gnatinstallhandler.c
+ ../../shared/gnatinstallhandler.c \
+ ../shared/src/memcpy.c
# start
libbsp_a_SOURCES += startup/start.S
-# clock & timer
-libbsp_a_SOURCES += ../../../libcpu/@RTEMS_CPU@/ppc403/clock/clock.c
-libbsp_a_SOURCES += ../../../libcpu/@RTEMS_CPU@/ppc403/timer/timer.c
-
# console
libbsp_a_SOURCES += startup/dummy_console.c \
../../shared/dummy_printk_support.c
@@ -53,6 +50,10 @@ libbsp_a_SOURCES += startup/dummy_console.c \
include_bsp_HEADERS += include/irq.h
libbsp_a_SOURCES += irq/irq_init.c
+# mmu
+include_bsp_HEADERS += include/mmu.h
+libbsp_a_SOURCES += mmu/mmu.c
+
#vectors
include_bsp_HEADERS += ../../../libcpu/@RTEMS_CPU@/@exceptions@/bspsupport/vectors.h
include_bsp_HEADERS += ../../../libcpu/@RTEMS_CPU@/@exceptions@/bspsupport/irq_supp.h
@@ -60,7 +61,9 @@ include_bsp_HEADERS += ../../../libcpu/@RTEMS_CPU@/@exceptions@/bspsupport/irq_s
libbsp_a_LIBADD = ../../../libcpu/@RTEMS_CPU@/@exceptions@/rtems-cpu.rel \
../../../libcpu/@RTEMS_CPU@/@exceptions@/exc_bspsupport.rel \
../../../libcpu/@RTEMS_CPU@/shared/cache.rel \
- ../../../libcpu/@RTEMS_CPU@/shared/cpuIdent.rel
+ ../../../libcpu/@RTEMS_CPU@/shared/cpuIdent.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/clock.rel \
+ ../../../libcpu/@RTEMS_CPU@/ppc403/timer.rel
EXTRA_DIST = times