summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 12:49:31 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-30 12:49:31 +0000
commit8a13fe8172fe318c0ad2b4c4c4318505d1452b32 (patch)
treefa8804d8be1e5f405db96dcbdde235a76233ee13 /c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am
parent2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-8a13fe8172fe318c0ad2b4c4c4318505d1452b32.tar.bz2
2004-01-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add RTEMS_PROG_CCAS. * Makefile.am: Use automake compilation rules.
Diffstat (limited to 'c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am')
-rw-r--r--c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am36
1 files changed, 18 insertions, 18 deletions
diff --git a/c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am b/c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am
index e20d9b3150..61b7ff11fa 100644
--- a/c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/support/old_exception_processing/Makefile.am
@@ -4,32 +4,32 @@
ACLOCAL_AMFLAGS = -I ../../../../../aclocal
-# C source names
-C_FILES = cpu.c
-C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+include $(top_srcdir)/../../../../../automake/compile.am
+
+EXTRA_PROGRAMS =
+CLEANFILES =
+noinst_DATA =
include_rtems_scoredir = $(includedir)/rtems/score
include_rtems_score_HEADERS = rtems/score/ppc_offs.h
-# Assembly source names
-S_FILES = cpu_asm.S
-S_O_FILES = $(S_FILES:%.S=${ARCH}/%.$(OBJEXT))
-
-include $(top_srcdir)/../../../../../automake/compile.am
-include $(top_srcdir)/../../../../../automake/lib.am
-
AM_CPPFLAGS += -I$(srcdir)
-REL = $(ARCH)/rtems-cpu.rel
-
-$(REL): $(C_O_FILES) $(S_O_FILES)
- $(make-rel)
+EXTRA_DIST = TODO irq_stub.S ppccache.c
-all-local: $(TMPINSTALL_FILES) $(REL)
+EXTRA_PROGRAMS += rtems-cpu.rel
+CLEANFILES += rtems-cpu.rel
+rtems_cpu_rel_SOURCES = cpu.c cpu_asm.S rtems/score/ppc_offs.h
+rtems_cpu_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_OPTIMIZE_V)
+rtems_cpu_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-UNUSED_FILES = irq_stub.S
+EXTRA_PROGRAMS += rtems-cpu_g.rel
+CLEANFILES += rtems-cpu_g.rel
+rtems_cpu_g_rel_SOURCES = $(rtems_cpu_rel_SOURCES)
+rtems_cpu_g_rel_CPPFLAGS = $(AM_CPPFLAGS) $(CFLAGS_DEBUG_V)
+rtems_cpu_g_rel_LDFLAGS = $(RTEMS_RELLDFLAGS)
-EXTRA_DIST = TODO $(C_FILES) $(S_FILES) $(UNUSED_FILES)
+noinst_DATA += rtems-cpu$(LIB_VARIANT).rel
PREINSTALL_DIRS =
PREINSTALL_FILES =
@@ -43,7 +43,7 @@ $(PROJECT_INCLUDE)/rtems/score/ppc_offs.h: rtems/score/ppc_offs.h $(PROJECT_INCL
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/score/ppc_offs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/score/ppc_offs.h
-CLEANFILES = $(PREINSTALL_FILES)
+CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/../../../../../automake/local.am