summaryrefslogtreecommitdiffstats
path: root/c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-31 00:37:44 +0000
commit66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f (patch)
tree2777029b9878ae5869c4215740c1054bc78a1bca /c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am
parent2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-66ae7d0b9fd9cce1b7121d84f677c1ef23fc0e6f.tar.bz2
2004-01-31 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am. Use automake compilation rules. * clock/Makefile.am, console/Makefile.am, PCI_bus/Makefile.am, startup/Makefile.am, timer/Makefile.am, tod/Makefile.am, vectors/Makefile.am: Remove. * configure.ac: Reflect changes above. * wrapup/Makefile.am: Reflect changes above.
Diffstat (limited to '')
-rw-r--r--c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am b/c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am
index de32de186c..2fae0dbd9c 100644
--- a/c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am
+++ b/c/src/lib/libbsp/powerpc/score603e/wrapup/Makefile.am
@@ -2,11 +2,12 @@
## $Id$
##
-BSP_PIECES = startup clock console timer tod vectors PCI_bus
+OBJS = ../startup$(LIB_VARIANT).rel ../clock$(LIB_VARIANT).rel \
+ ../console$(LIB_VARIANT).rel ../timer$(LIB_VARIANT).rel \
+ ../tod$(LIB_VARIANT).rel ../vectors$(LIB_VARIANT).rel \
+ ../PCI_bus$(LIB_VARIANT).rel
-# bummer; have to use $foreach since % pattern subst rules only replace 1x
-OBJS = $(foreach piece, $(BSP_PIECES), ../$(piece)/$(ARCH)/*.$(OBJEXT)) \
- ../@exceptions@/$(ARCH)/*.rel
+OBJS += ../@exceptions@/$(ARCH)/*.rel
include $(top_srcdir)/../../../../automake/compile.am
include $(top_srcdir)/../../../../automake/lib.am